Support » Fixing WordPress » Permalinks Not Found

  • Resolved AzureDesigns

    (@azuredesigns)



    My permalinks are not working. I have set it to post name and although I can see the correct link when scrolling over, when I click it I get the following:

    Not Found

    The requested URL /azure0designs/index.php was not found on this server.

    I have worked on other sites before and they usually work, so I’m a little confused. I have researched and checked the following:

    I have added the following to htaccess
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    I have checked everything written on – Users of WAMP (Windows): and all is correct.

    My rewrite_module is checked.

    What else am I missing?? Please help

Viewing 15 replies - 1 through 15 (of 17 total)
  • Moderator Marius L. J.

    (@clorith)

    Hi,

    The error you are getting is an indicator of mod_rewrite not being enabled. Did you restart after enabling it? (It doesn’t start working until you restart the webserver)

    Hi Marius

    Yes, I restarted All services and restarted my pc.

    (I’m working locally by the way)

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    Don’t forget that you also have to enable it in the Directory section with AllowOverride All too.

    Hi Jan

    I have changed to All. This is what I have but it’s now going to another site I have designed???

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    Order deny,allow
    Deny from all
    </Directory>

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    That’s good but for it to take effect you’ll need to restart Apache2. On WAMP that’s restart the service.

    The requested URL /azure0designs/index.php was not found on this server.

    Is /azure0designs/ the directory where you installed WordPress?

    Yes

    If I turn permalinks back to default everything works fine

    I so want the permalinks to be set to post name though…

    Moderator Marius L. J.

    (@clorith)

    Would you mind sharing the virtual host you are using for the WordPress site?

    I’m not sure what you mean. I haven’t uploaded yet and am working locally.

    Moderator Marius L. J.

    (@clorith)

    Well you showed a <Directory> block, do you have one of those for the WordPress site, or is that the only one you have?

    If that’s the only one, have you tried adding AllowOverrides all to the default value, or making a <Directory /azure0designs/> block for your WordPress folder?

    under the httpd config file I also have

    <Directory “C:/Lisa Data/wamp/www/”>
    #
    # Possible values for the Options directive are “None”, “All”,
    # or any combination of:
    # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that “MultiViews” must be named *explicitly* — “Options All”
    # doesn’t give it to you.
    #
    # The Options directive is both complicated and important. Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be “All”, “None”, or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride all

    #
    # Controls who can get stuff from this server.
    #

    # onlineoffline tag – don’t remove
    Order Allow,Deny
    Allow from all

    </Directory>

    Not sure if this is what you mean… it’s starting to get a little confusing for me. I also have the following

    <Directory “cgi-bin”>
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>

    Moderator Marius L. J.

    (@clorith)

    Hmm,

    That does look fine. Let’s do a quick test, in your .htaccess file remove these two lines:

    <IfModule mod_rewrite.c>
    </IfModule>

    When you now try to visit your website does it show an error? (You can replace them right after, just want to see if it gives any errors relating to mod_rewrite or not)

    Oh no this is going from bad to worse. My WAMP is not working anymore it’s stuck on orange. I decided to restart all services and now this has happened

    I realise that deleting what you mentioned above wouldn’t change my WAMP setting so now I’m totally baffled. Maybe I should uninstal wamp and reinstal. Okay did that and my wamp stopped working. I will try that and let you know

    Moderator Marius L. J.

    (@clorith)

    Do let me know how it goes. Some things to keep in mind though is that WAMP will be orange if it can’t open Apache, this is usually caused by something using port 80 (Skype and TeamViewer are very common reasons for this as they both try to use port 80)

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Permalinks Not Found’ is closed to new replies.