Permalinks not Displaying in Recent Posts (6 posts)

  1. JamesKern
    Posted 4 years ago #

    Hi guys,

    I have added posts to my wordpress site but I noticed that recent posts widget is not displaying the correct link to the posts. Instead its like this:

    Article Name - The link for this is http://www.sitename.com//
    Article Name - The link for this is http://www.sitename.com//
    and so on etc

    I had this blog located at http://www.site.com/blog and then migrated it with backupbuddy to the root folder and new wordpress database etc. This hardly affected the recent posts plugin?

    All other plugins work perfectly e.g related posts etc and my permalinks are set to /%postname%/
    I've double check the wordpress URL is correct but I just cannot work this out.

    Please help me out guys if you have any idea whats going on


  2. JamesKern
    Posted 4 years ago #

    I should add that I'm using the twentyten standard theme and also when I try going to http://www.site.com/article-name/ it goes to the article perfectly.

    My only problem is the recent posts widget showing the wrong link to them.


  3. Sennza Pty Ltd
    Posted 4 years ago #

    Hey there,

    I've had that one before too. Try looking under Settings -> General in and check the WordPress address (URL) and Site address (URL) fields. If the both have a trailing slash e.g.http://www.sitename.com/ then change them both to http://www.sitename.com and you should be set.

    I you can't edit them then look in your wp-config.php and look for `define('WP_SITEURL', 'http://www.sitename.com/');
    define('WP_HOME', 'http://www.sitename.com/');`

    and change that to:

    define('WP_SITEURL', 'http://www.sitename.com');
    define('WP_HOME', 'http://www.sitename.com');

    Hope that fixes it for you!

  4. JamesKern
    Posted 4 years ago #

    Hi Bronson,

    I checked both again and they are normal (no trailing slashes). I also had a look at my wp-config.php but that code isn't there?

    Would you mind checking out this post I came across about htaccess setting for permalinks.


    My htacess has an extra line in it, could that be the problem?

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]      <----------------THIS
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    I don't want to change it incase it does damage like

    Thanks for your help!

  5. Tara
    Volunteer Moderator
    Posted 4 years ago #

  6. JamesKern
    Posted 4 years ago #

    Anybody else have any idea whats going on?

    I really need to get this problem sorted out as quick as possible

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.