[resolved] permalinks issues with sub-direcory multisite install (9 posts)

  1. tique
    Posted 3 years ago #

    im have been having issues with permalinks for sub-directory multisite installs...
    this is for a local install [localhost] and therefore multisite install is restricted to using sub-directory's only... that is ok as thats what i want anyway...

    1. i install the latest wordpress in a local directory.
    2. i install a multisite as per: http://codex.wordpress.org/Create_A_Network
    3. permalinks are set to 'Day and name'.

    problem: links to the sample page and post can not be found.

    i have mod_rewrite installed and my .htaccess file seems ok

    i have looked around and there seems to me to be a lot of confusion around this issue... from what i understand it can be tricky but not impossible...
    is this set-up bound to fail every time in the most simplest case?
    or am i missing something really basic?



  2. So ... what's the error your getting? Do they just not work? Do ugly permalinks work?

    What's in your .htaccess?

    (FWIW, they DO work, out of the box, for most people, but when they don't (ESPECIALLY on localhost) it's usually a config error in apache.)

  3. tique
    Posted 3 years ago #

    hi mika, thanks for the quick reply,
    im getting the:

    Not Found
    The requested URL /arbeit/sample-page/ was not found on this server.

    only the default permalink settings works... i.e. ?p=123...
    here is my .htaccess file:

    RewriteEngine On
    RewriteBase /arbeit/
    RewriteRule ^index\.php$ - [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    i installed LAMP using tasksel in ubuntu 12.04... so its pretty "out of the box", id like to know what could be wrong with my apache config...

    thanks again...

  4. tique
    Posted 3 years ago #

    ill have a look at apache and see what i can find...

  5. How is the 404 formatted? Does it look like a WordPress 404 or a server one?

  6. tique
    Posted 3 years ago #

    thanks again,
    it looks like its from apache...
    i just tried this .htaccess out:

    RewriteEngine On
    RewriteRule ^google.html$ http://www.google.com/ [R=301]

    i tried to access google.html to get a redirection but i get "not found"...
    so i was thinking that mod_rewite isnt installed properly ...

    yet phpinfo() displays that mod_rewite module is loaded...

    Loaded Modules	core mod_log_config mod_logio prefork http_core mod_so mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_deflate mod_dir mod_env mod_mime mod_negotiation mod_php5 mod_reqtimeout mod_rewrite mod_setenvif mod_status


  7. tique
    Posted 3 years ago #

    ha... i finally found the issue...
    you were correct...
    the AllowOverride directive for my site's directory was set to none... so i changed it to all... [

    permalinks now work...

    thanks again for pointing me in the right direction

  8. arthur-p
    Posted 3 years ago #

    This is really a very critical missing link. On Ubuntu 12.04 the default setting for allowoveride is indeed off. The only way I could get mutlisite to work more or less was to install symbolic links with subdir names linking back to the root for the wordpress instalation, but that did not work well with various extensions. This has had me stumped for several days until I ran into your last post. Finally the multisite seems to install as advertised.

    The need to change this should be added to the multisite install instructions:

    If mod-rewrite is enabled, but you get an apache 2 error message that the subdirectory URL cannot be found, then in the file /etc/apache2/sites-enabled/000-default (or actual the file this link points to): change 'AllowOverride none' to 'AllowOverride all'.

  9. DancingFighterG
    Posted 2 years ago #

    Been looking for a while for a solution to this. One thing that everyone should know is if you are on a shared host most of the time they will not make that change on the server for you which sucks.

Topic Closed

This topic has been closed to new replies.

About this Topic