WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Permalinks issue :: Apache server specs???

[Resolved] Permalinks issue :: Apache server specs???

  • mrkingid

    @mrkingid

    I have posted about this before but it had to do with a site I transfered over. This time around it is a new site and there is no reason permalinks shouldn’t work

    What I have found is that the servers for the sites that the permalinks are NOT working is:
    SERVER_SOFTWARE Apache/2.0.54 (Debian GNU/Linux) FrontPage/5.0.2.2635 mod_ssl/2.0.54 OpenSSL/0.9.7e

    But the server with the site with permalinks WORKING is:
    SERVER_SOFTWARE Apache/1.3.37 (Unix) mod_tsunami/3.0 FrontPage/5.0.2.2634

    Could the Apache server software version be the issue?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Permalinks depends on mod_rewrite and its configuration settings in .htaccess. Usually the mod_rewrite is enabled so you only may need to create the .htaccess file as described here: http://codex.wordpress.org/Using_Permalinks

    mrkingid

    @mrkingid

    .htaccass is made and mod_rewrite is on but on both sites permalinks don’t work.

    mrkingid

    @mrkingid

    What is:

    The FollowSymLinks option enabled

    and can I enable it or is it an apache server side thingy

    mrkingid

    @mrkingid

    HOLY SH*** I FOUND IT!!!!!!!!!!!!!!!!!!!

    Wooohoooooo!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    For those two servers I have to add ‘Options FollowSymLinks
    ‘ to the .htaccess file.

    So it would look like…

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    Options FollowSymLinks
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Damn…. over three months it has taken me to find the solution!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    Sweet

    **HAPPY DANCE**HAPPY DANCE**HAPPY DANCE***

    xjessie007@yahoo.com

    @xjessie007yahoocom

    Quote wpbct7:

    Usually the mod_rewrite is enabled….

    mod_rewrite is usually not enabled. Most of the time, hosting providers have it disabled and you have to do some job find one that has it enabled, just my experience…

    Just for the sake of clarity…
    When enabling FollowSymLinks, it has to be defined in two places:

    First, FollowSymLinks needs to be enabled in httpd.conf. Here is an example what you might want to have in your httpd.conf.

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Satisfy all
    </Directory>

    Second, FollowSymLinks may need to be mentioned in .htaccess too. Here is an example
    Options +FollowSymLinks

    Third, know that FollowSymLinks improves the performance slightly. The effect is almost negligible, but just so you know. Whenever you can, use FollowSymLinks.

    Fourth, FollowSymLinks is good for security. You can hide your true location of your files and folders through it.

    Here is a good page on FollowSymLinks
    FollowSymLinks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Permalinks issue :: Apache server specs???’ is closed to new replies.
Skip to toolbar