WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Permalinks Issue

[Resolved] Permalinks Issue

  • My website’s url.

    When you load the homepage, the image doesn’t load (and this is occurring site-wide). When I checked the permalink structures, they somehow (without my permission) changed. When I went to save them to my own custom format (/%postname%/), it said it saved, but the blue button remained on /sample-post/.

    Why is this happening and how can I get it to revert?

    Blessings,

Viewing 15 replies - 1 through 15 (of 30 total)
  • To change permalinks the .htaccess file must be writeable. 644 is the recommended setting when you want WP to create it.

    http://codex.wordpress.org/Using_Permalinks

    Christine Rondeau

    @crondeau

    Volunteer Forum Moderator

    I just visited your site and the permalinks look good to me.
    I’m not sure what you mean about the image not loading on the home page?
    I see a blue background with a slider with images….

    Look down underneath the slider. Go to the ‘about’ page for more examples.

    Knut – the .htaccess file is 644.

    Any other ideas?

    The image URLs are, “https://www.mydomain.com/mydomain.com/wp-content/uploads/2011/08/mydomain_home_1.jpg” when they should only be, “https://www.mydomain.com/wp-content/uploads/2011/08/mydomain_home_1.jpg”.

    Note again – my permalinks will not change after being saved, and my .htaccess’ permissions is 644.

    Blessings,

    esmi

    @esmi

    Forum Moderator

    Check your uploads path in Settings->Media. It should be blank in most installs.

    It’s blank.

    esmi

    @esmi

    Forum Moderator

    Did you move WordPress after it was installed?

    Other than adding a SSL, no. The SSL was added a week ago, so I doubt the issue is linked.

    esmi

    @esmi

    Forum Moderator

    So you installed WP initially under https? If not, how did you make the url changes?

    I didn’t; I changed the URLs manually through WP and the database. However, this issue wasn’t present during the change.

    When changing the permalinks, WP does NOT like /%postname%/ but it DOES like /%postname%.

    Any reasons why?

    PS: whenever I changed it to /%postname%, I still have the error of loading images.

    Blessings,

    I changed them to /%postname% and it ‘saved’, however, my links are still ALL broken (maybe minus menus), and my images aren’t loading either.

    Thoughts?

    Blessings,

    Hey Joe i have faced the same problem on my website http://www.visionworldtech.com/automation.. SO i searched a lot and come on conclusion that most of the cache plugins are the main reason of this actually they change the htaccess file So As i am using W3total cache so first i removed it manually and then change the permalink as %postname% and saved it so all done… But remember remove the plugin manually

    Hey – thanks for the advice.

    I manually deleted my cache plugin, and the error still remains.

    Any other ideas?

    I deactivated ALL of my plug-ins, and still have the error.

    Thoughts..?

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘[Resolved] Permalinks Issue’ is closed to new replies.
Skip to toolbar