WordPress.org

Support

Support » Multisite » [Resolved] Permalinks in Multisite…

[Resolved] Permalinks in Multisite…

  • mamaestes
    Member

    @mamaestes

    I cannot find the permalinks to edit them. Nothing under Options or Setting menu. Can someone tell me where to find the permalinks options?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Permalinks are per-site.

    When you set up your network, you were given the .htaccess code to put in. Once you do that, Permalinks are in the normal place.

    Settings -> Permalinks

    mamaestes
    Member

    @mamaestes

    I must not have the correct htaccess code because the menu doesn’t appear on any of the blogs on our multisite install…this is what we have in our htaccess file…can you tell me if it’s correct?

    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    website url is http://blog.burlesonisd.net

    mamaestes
    Member

    @mamaestes

    If you’re logged in as the Super Admin, it should be there.

    Unless you have a conflicting plugin.

    Note the plugin above forces all sub blogs to have the *same* permalink structure. It;s not a fix of anything, really. Just an option.

    mamaestes
    Member

    @mamaestes

    It got the permalinks back to their original structure so the teachers could use it until I found the plugin causing the problem (thanks for that suggestion ipst4enu). Got rid of offending plugin and all is back to permalink bliss. Thanks guys. I appreciate the speedy replies!

    Yeah, mostly being overly specific for anyone reading along. 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Permalinks in Multisite…’ is closed to new replies.