WordPress.org

Support

Support » How-To and Troubleshooting » Permalinks in 2.6.1 still not working

Permalinks in 2.6.1 still not working

  • Greetings all,

    Im a relatively new WordPress user, started using it when it was in stage 2.4 or 2.5. I managed to have no problems what so ever with anything except now ever since I’ve upgraded to 2.6 the permalinks problems started happening. As a good techy, I read all the documentation and tried the various fixes (of which none of them worked for me) So I decided to wait till 2.6.1 which was supposed to address the permalinks issues associted with people using IIS.

    I upgraded to 2.6.1 this morning and Im sorry to say that the permalinks are still not working.

    Ive tried adding Category and Tag, Ive tried not using “index.php” in the link structure, Ive tried every possible combination of link structure and “hacks” but absolutely none of them work except for the default or numeric link structure. This is the reason why I’ve kept my other blog at 2.5 which works perfectly.

    Please someone give me a recommendation, as i’ve run out of ideas and probably read every post on permalinks on this website.

    Again I am a IIS user

    Thank you for your time!

Viewing 15 replies - 1 through 15 (of 48 total)
  • Hi guys… Still need help on this. I’ve tried updating the database and applying the fixes mentioned in the sticky on this forum and still no luck. Im not sure what the problem is.

    OK, add me to the mix. I upgraded to WordPress 2.6.1 and tried all of the fixes that a moderator posted (he closed the thread). I still have “spaces” for my categories and a number, but no description shows up.

    Add me to the list. My permalink structure was %postname% and now all pages are going to a 404.

    Okay, I messed around with 2.6.1 and this is how I got my pretty permalinks to work again. Previously I was using %postname% and it broke. Tried using index.php/%postname%/ and that didn’t work.

    Solution:
    Use custom structure: %PATHINFO%/

    This will yield the following permalink:

    http://yoursite.com/postname/

    Same problems for me. A 404 Error.

    Not even desertmagic’s solution of using %PATHINFO% worked. (but thanks for posting it — it may work for some, which is a good thing).

    My other blog is running fine on 2.5, and custom structure:%postname% works perfectly.

    Created a new blog, v. 2.6, and permalinks would not work. Heard the permalinks was a common problem, and 2.6.1 would fix it — didn’t for me. I hope I don’t need to revert back to 2.5 for the new blog, but it beats having numbers, dates, and symbols in the URL (for this particular site)…

    Ok, I found another solution that worked for me, though not sure why it worked… but it did.

    When setting up the 2.6.1 blog, instead of going straight to the Permalinks tab in Settings first (as I did), go to the “General” page first.

    In the field “WordPress address (URL)”, change the url to either have the “www” or not. Click “Save Changes” on the bottom of the page. Then change it back. Repeat, at least to get it to whichever you’ll want your blog.

    Then go back to Permalinks, and use /%postname%/ (as I chose), or whatever format you wish. Bingo. It now works.

    Apparently, tinkering with the url settings in the “General” section first, causes WP to create whatever necessary thinga-ma-jigs that are needed to do the permalink stuff. (Pardon the caveman terminology, it’s 5 AM)

    Still not working for me :-((((

    Same problems for me. A 404 Error as well. I have tried all of the previous solutions and the solutions listed in this support post. I am running IIS as well.

    I thought this issue was resolved…Even when adding the category and tag base names it does NOT work.

    Anyone have any ideas? Thoughts? A rock to hurl at the wall?

    I’ve tried all the solutions mentioned above and I am still not able to get my permalinks running as well. Is there any way to switch back to 2.5 without doing any damage? 2.6 or 2.6.1 just have not been working well and Im running out of time playing around with these permalinks 🙁

    Hello All,

    Just tried a completely fresh install, fresh download of 2.6.1, new database and I still have the same permalink issues I had previously. Unless I use the horrible URL of “p=some number no one will ever remember”. I receive a 404 on every page with the exception of my blogs home page.

    I have tried adding a category base and a tag base as well and still push nothing but 404’s.

    Anyone else have any luck with this as of yet?

    I tried both solutions here – i.e. “pathinfo” as well as the General settings tinkering thingy. Both didn’t work for me.

    Can anyone help please?

    Good grief! I have no idea why this is happening but I got my permalinks to HALF work.

    My permalinks (before the 2.6 nightmare) used to be in the format:
    http://uptowngal.org/blog/2008/08/19/sample-post/

    Then WP 2.6 came and they got all broken and nothing could fix it.

    After the upgrade to 2.6.1, they still didn’t work. HOWEVER, by selecting a “Custom Structure” in my permalinks setting page and using:
    /index.php/%year%/%monthnum%/%day%/%postname%/

    I now get this:
    http://uptowngal.org/blog/index.php/2008/08/19/if-i-could-take-a-pic/

    So I get my post name as part of the URL, but there’s this “index.php” there. Anyone knows why?!?!??

    @uptowngal

    I believe “index.php” is inserted into the permalink due to an IIS issue due to its lack of the mod_rewrite function.

    There is a post on it here:

    FIX: 2.6 Permalink issues with “index.php

    Hope that helps…

    Note: That article did not solve my permalink issues described further up in this post.

    Re-tried all steps this morning…no dice. Anyone have any ideas?

    We’ve spent HOURS on the permalink issue as well. Went from (I think) 2.1 to 2.6 and lost categories as well as permalinks. As long as we used the default link structure, it was OK. (rebuilt the categories to fix)

    We also had a new RSS feed address (old one involved index.php, new one didn’t). RSS feed issue was fixed when we upgraded to 2.6.1 yesterday.

    We’ve tried EVERY recommended solution for the permalinks. Finally found one that worked:
    index.php/%year%/%monthnum%/%day%/%postname%/

    We’re running Apache.

    If you have a blog at index.php on Apache, definitely try the index.php custom path.

    Thanks all for the help…

    (edited to clarify upgrade to 2.6.1)

Viewing 15 replies - 1 through 15 (of 48 total)
  • The topic ‘Permalinks in 2.6.1 still not working’ is closed to new replies.
Skip to toolbar