WordPress.org

Support

Support » Installation » permalinks, .htaccess, and broken everything!

permalinks, .htaccess, and broken everything!

  • OK, this is ridiculous. I want the permalink to read /year/month/day. So I know that I have my .htaccess file correct according to eveerything I’ve read.

    Now I’m not getting any erros with the links themselves, rather, they load the URL just fine – but they don’t update the page!! As in, click “previous” and the URL changes to yesterday’s date, no problem. Picture, title, everything displayed in the browser stays exactly the same.

    And, if I ask it to link to the archives, it gives me a “Server Not Found” error!

    Using WordPress 2.0.2, here:

    # BEGIN WordPress
    RewriteBase /comic/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ./comic/index.php/%year%/%monthnum%/%day%/%postname%/ [L]
    # END WordPress

    Any ideas? …It’s getting reaaally frustrating.

Viewing 15 replies - 1 through 15 (of 24 total)
  • Mark (podz)

    @podz

    Support Maven

    Do you have a link?
    It’s easier to test things out by clicking on the actual problem.

    I would, but we’ve set everything back to the normal linking ( =?123 ) so the site was usable. everything works so long as we don’t touch the link format. Imagine this: there’s the calendar. You click “16”. The URL changes to ../2006/April/16/post/ and the browser continues to display today’s post.

    Those variables (%year%, etc) are WP permalink variables, not mod_rewrite ones. ie: Apache doesn’t understand those.

    Did you write the rule yourself or use the permalink panel in WP admin?

    Make your .htaccess file writable (CHMOD 777)and then go back to the permlink settings and select your format.

    I beleive this will fix your problem, so long as your .htaccess is writable. WordPress will rewrite your file accordingly. Mine differs slightly:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    You will be able to note the changes in the files administration pages as mentioned.

    Once acheived, CHMOD your .htaccess back to 444

    As some posts have suggested I’ve tried: deleting my .htaccess, changing read/write permissions, I’ve hand writen the htaccess, let WP write it, playing with /%year%/%monthnum%/%day%/%postname%/, reinstalling wordpress, reinstalling the mysql DB, switching back to a default theme and changing my PHP. I must be missing something obvious. I changed it back so you can see it in action.
    http://angryteeth.net/comic/

    What is your WordPress address and Blog address in General Options admin panel and do you redirect /comic/ to /comic/nfblog/ by htaccess or other means?

    WordPress address (URI): /comic/nfblog
    Blog address (URI): /comic

    I just used the WordPress panel to change it. It seemed to work fine when I was using the ?p=123 option

    Do you have a /comic/index.php ? If so, what’s in it?

    <?php
    /* Short and sweet */
    define(‘WP_USE_THEMES’, true);
    require(‘./nfblog/wp-blog-header.php’);
    ?>

    That index.php looks right. Do you have a .htaccess in the nfblog directory? If so, rename or move it away and see if that’s the cause.

    I only have .htaccess files in the www/ and www/comic/ directories and I’ve tried it with out the one in the www/

    I have the same problem — fresh install, change the permalink and, bam, everything is broken. Only when I delete .htaccess is the site even viewable, but permalinks remain broken. Do I need to somehow hack the basic install?

    I notice you’re on Netfirms. I am also and have the same problem. It seems to be the way the host has configured Apache conflicts (or doesn’t work) with the way WP 2.x utilizes permalinks. I been searching everywhere and found no solution. Although netfirms states that they support this feature, i don’t think they actually do.

    Their site suggests placing index.php before the permalink variables, which seems odd. But if you do that it will actually work correctly.

    http://support.netfirms.com/idx.php/57/669/Netfirms-WordPress/article/How-do-I-create-search-engine-safe-URLs-in-Wordpress.html

    I’m using Host My Site and the index trick didn’t work for me =(

    Here’s what my service provider says:

    <b>That error is because we don’t allow RewriteRules in individual .htaccess files. When you change your permalinks, WordPress tries to add RewriteRules to your .htaccess file, which in turn gives an error since we don’t allow that.

    We can add these rules to your server configuration file. All we’d need is a copy of the RewriteRules, which I believe your should be able to get from WordPress. Once we have those rules, we’ll add them to your site and you shouldn’t get the error anymore.
    </b>

    Anyone know what the RewriteRules are? I can’t seem to locate them in WordPress…

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘permalinks, .htaccess, and broken everything!’ is closed to new replies.