Support » Fixing WordPress » Permalinks – how is this not addressed yet?

  • Hi folks,

    A few days ago I posted about permalinks, and I came back today to check again for responses by sadly none. I see other WP users having the same issue, but no solutions. How is it such a widespread issue has no resolution as of yet? I love WP, don’t get me wrong but I’m perplexed as to why it’s still lingering.

    Basically, it seems as if the only current permalink option that works is the default. With .htaccess being writable, and the config updated and so forth several times – only the default works. Hell, even if I try to access /wp-admin/ after changing from the default permalink option in the config it 404’s. The only remedy to getting back into the admin at that point is to remove .htaccess or remove the WP-added lines.

    Any ideas?


Viewing 5 replies - 1 through 5 (of 5 total)
  • Did you check that your web host has the mod_rewrite Apache module?

    For permalinks info and troubleshooting, see:

    Using “Pretty” permalinks

    Hey, Jayemm,

    I am among the WordPress users whose pretty permalinks stopped working after I upgraded to 2.7 on March 27. I have posted several questions on this Forum and received a lot of input from users and moderators, but after trying many options, I still can’t get my permalinks to work.

    I am on MidPhase (recommended company!) and upgraded thru Fantastico. The upgrade worked from 2.5 to 2.6 a year ago, no problem, but this time around it’s a disaster.

    Yes, my web host has mod_rewrite Apache. I have contacted them numerous times to try to help me, and they have no solutions.

    I deeply, deeply regret upgrading to 2.7. I don’t believe in WordPress any more. This permalinks issue is a major problem, and it’s caused me to lose most of my blog traffic and weeks of time.

    I see no one has responded yet to my last post.

    Can anyone provide more recent information about the 2.7 permalinks bug? I have been trying for three weeks to fix my blog with no success.

    You have the .htaccess in the root folder of the site, right?
    Having it in the WordPress (blog) folder does nothing, or you need it in both, I’m not sure.

    I just know that as soon as I put a copy of the .htaccess folder that I had in my blog folder into my sites root folder, it worked for me.

    I was getting the 404 error if I used anything but the default before that.

    Yes, geezerd, I have the .htaccess in the root folder. I don’t have it anywhere else. I’m running a blog, not a blog within a website.

    Where else would I put it in addition to the root folder?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Permalinks – how is this not addressed yet?’ is closed to new replies.