WordPress.org

Support

Support » How-To and Troubleshooting » Permalinks help

Permalinks help

  • I am trying to switch my URL structure from using categories to dates but when I switch to “Day and name” from “Custom Structure” articles don’t load when clicked on the homepage.

    Any suggestions?

Viewing 8 replies - 1 through 8 (of 8 total)
  • You may need to clear your cache. Does it happen if you try a different browser?

    Hi,

    Reset your desired wordpress permalink from wordpress admin area and add this code in htaccess of your blog/site:

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Now, check with blog posts and pages.

    Thanks,

    Shane G.

    Thanks guys, I’ll give all the above a try!

    WP should write that to your .htaccess file automatically. If it doesn’t, you may have incorrect permissions on the server.

    I tried both of these and it’s still not working. 🙁

    mod_rewrite enabled?

    whats mod_rewrite?

    it is what you need if you’re going to get pretty Permalinks working 🙂

    Check out the Using_Permalinks page in the docs section of this site. There are a bunch of trouble-shooting tips there to look over.

    Do you manage the server or is it a shared host?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Permalinks help’ is closed to new replies.
Skip to toolbar