Support » Fixing WordPress » Permalinks have a /index.php/ in the path

Viewing 7 replies - 1 through 7 (of 7 total)
  • Do you have an htaccess file in the root directory of your installation?
    http://codex.wordpress.org/htaccess

    yes, it contains:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    is that correct

    those look out of order.missing stuff slightly and may be causing your issue.

    Replace with this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Thanks so much, I will upload new code. What is the best way to clear my WP cache so the new .htaccess file is loaded. Not sure which plugin to use?

    It is not a good idea to change permalinks directly in .htaccess. Go to Dashboard>>Settings>>Permalinks and change them there. See if your permalink structure has /index.php/ added to it. If so, go with another structure. If you’re on a windows server, you may have to use index.php in permalinks. Ask your webhost.

    Thanks songdogtech,

    This is new client’s host and I think you’re right, it is probably a windows server. I had no idea a windows server might use this /index.php/ (never saw it before on any host I’ve worked with). Hopefully the host has a work around.

    http://sitename.com/about

    is much better than

    http://sitename.com/index.php/about

    thanks again, I’ll post a solution once I talk with the host.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Permalinks have a /index.php/ in the path’ is closed to new replies.