WordPress.org

Forums

[resolved] Permalinks going to 404 (7 posts)

  1. desmondo
    Member
    Posted 7 years ago #

    Hi all,

    I have gone through all the trouble shooting guides and I still can't get the Permalinks to work. I am on a Mac, using OS X 10.4.10. Here is what I have done:

    - I have made sure that WordPress can edit the htaccess file, it now writes the conditions automatically when I click update permalinks.

    - I have gone into the httpconf files for both Apache and my username and changed the allowoverride to ALL. I have also checked that mod_rewrite is enabled.

    - I have restarted Apache, nothing changes.

    Does anyone have anything else I can try?

    Here is the URL I am trying to test:
    http://localhost/content/news/permalinks-test/

    (I have made sure the htaccess is in the root directory of "content" which is where the WordPress lives.

    Cheers

  2. moshu
    Member
    Posted 7 years ago #

    Since only you can see it - why does it matter what the permalinks are? :)

  3. desmondo
    Member
    Posted 7 years ago #

    Umm, it will be uploaded to a live server once all testing is done. Same as most sites that people build on their localhost.

    But back to the point, does anyone have any issues they have encountered with setting up Permalinks on Apache using OS X?

  4. moshu
    Member
    Posted 7 years ago #

    Again: will the live server machine be exactly the same (OS X etc.) or will it be a usual *nix box? If it's not the same... I don't understand the purpose of the question.

  5. desmondo
    Member
    Posted 7 years ago #

    It won't be the same, the usual *nix box I am assuming. I would still like to be able to set up Permalinks on my localhost, so I can link other pages on my website to the correct URL structure that will go live. So:

    http://localhost/content/student-stories/my-20th-post/

    Will still be:

    http://**LIVESITE**/content/student-stories/my-20th-post/

    So even if they are to work there, I won't be able to link to any of the pages until I go live, because the URLs would change. Hence why I would like to get Permalinks working on my localhost.

    I have found this post here:
    http://wordpress.org/support/topic/105874?replies=5

    Which sums up what I am experiencing. If I add the "index.php" to the permalink URL generated, it seems to work.
    http://localhost/content/index.php/student-stories/my-20th-post/

    This isn't the end result I'm after of course, I've tried everything mentioned on this page and still can't get them to work:
    http://codex.wordpress.org/Using_Permalinks

    Is there any other reason why mod_rewrite wouldn't work on a Mac?!

  6. moshu
    Member
    Posted 7 years ago #

    If you do it correctly the URL will NOT change - just learn a bit of WordPress :)
    You can set up the URLs correctly even in this situation:
    <a href="<?php bloginfo('home'); ?>/student-stories/my-20th-post/">lin text here <?a>

    assuming "student-stories" and "my-20th-post" will have the same hierarchical relation on the live site, too.

  7. desmondo
    Member
    Posted 7 years ago #

    OK, thanks for your help Moshu. As it turns out, I found a page which explained the Mac issue:
    http://face.centosprime.com/macosxw/?p=186

    Basically, I needed to add some options specific to the path of WordPress on my httpd.conf file:

    * <Directory /path/to/wordpress>
    * Options Indexes MultiViews SymLinksIfOwnerMatch
    * AllowOverride Options FileInfo
    * </Directory>

    This seems to have done the trick. After 5 hours, I now have permalinks working on my localhost!

    Cheers again

Topic Closed

This topic has been closed to new replies.

About this Topic