Support » Fixing WordPress » Permalinks, GoDaddy and I’ve tried everything

  • I’ve exhausted Google and the support forums. I’ve tried everything. And yet, I still cannot get pretty permalinks to work without the trailing slash at the end.

    This is how the permalinks were:
    http://www.interstateq.com/archives/3137/
    Users who left off the trailing slash were sent the standard GoDaddy 404 page.

    I wanted to change the structure to:
    http://www.interstateq.com/archives/3137
    That way, if someone left off the trailing slash they could still get to the post. If the trailing slash was left on when someone typed it, it would be automatically removed when they navigated to the post.

    I waited for hours (almost 24 to be exact), taking folks’ advice to just wait on .htaccess to update. Never worked.

    I tried changing the 404 error handling to “show my homepage.” That didn’t work either. Now the error page shows my root directory files. (I’ve switched that back to show interstateq.com/index.php to be safe, but that will take time to update.

    Of course, GoDaddy support insists that mod_rewrite is turned on.

    Does anyone have any advice at all?

    Oh, P.S. – If I change the permalink structure back to:
    http://www.interstateq.com/archives/3137/ the posts start showing again immediately.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I should also add… I operate another wordpress install on GoDaddy… http://www.q-notes.com... and it does not have this problem.

    Hi, I read all the forums, rang GoDaddy, and nothing worked.
    I was seeing a SideBar but a 404 in the main section of the page.
    The issue was because I had include %post_id% in the URl structure. Once I removed it all worked perfectly. BTW, there was also no need to wait for godaddy to refresh the htaccess file.

    Correction. The above worked only for ‘Pages’ it did not work for Blog ‘Posts’. I was able to see the Sidebar for my Posts but not the post content – just said 404. I tried the ‘404 fix’ on GoDaddy and this did not work (setting a custom 404 page equal to index.php). Eventually just moved to BlueHost – all now works. Avoid GoDaddy like the plague if you want to get Permalinks up and running easily. P.S. GoDaddy did not want to help – said it was a WordPress issue!

    FerroGate

    (@ferrogate)

    I know this is an old post, but I came across it while Googling the subject, and perhaps other will too. The solution is pointing to a custom 404 file. I posted about it here http://ferrogate.com/2009/04/the-new-ferrogate-i-moved-from-blogger-to-wordpress.html – a pretty lengthy post where I talk about moving from Blogger to WordPress, while keeping links and content intact.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Permalinks, GoDaddy and I’ve tried everything’ is closed to new replies.