Support » Plugin: Extended Post Status » Permalinks – Further Issue :(

  • Resolved JimDeadlock

    (@jimdeadlock)


    You previously said that making the status public would bring back the permalink. This is true. However, I just discovered to my horror that the actual post is made public by doing this.

    The problem here is that the status I want to use is “In Progress” – a place for authors to hold their post while working on it for an extended period. It does not want to be public, but at the same time it wants to be previewed by the author. Any way around this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • I have been having an issue with this as well. The only workaround I have found is to change the status to “draft”. This will restore the permalink and allow the author to preview without publishing the post.

    I hope, however, that the developer will find a way to restore the permalink for custom statuses, so that this isn’t necessary. Not much sense in having custom statuses for non-public posts if you have to change them every time you want to preview changes.

    Thread Starter JimDeadlock

    (@jimdeadlock)

    Yes, moving it back and forth kind of defeats the purpose.

    Plugin Author Felix W.

    (@welly2103)

    Hi @jimdeadlock / @goldmare

    with the current 1.0.17 release, an option has been added so that users with the right to edit posts also have the ability to see those posts with permalink, even if the status is not public. Does this solve the problem?

    Greetings Felix

    Thread Starter JimDeadlock

    (@jimdeadlock)

    Yes it does, thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.