Support » Fixing WordPress » Permalinks for site hosted on Windows Server

  • Hi,
    my site’s hosted on Windows Server and any time I try to modify the permalinks, it’s sudden death. The only way I know to fix it is to delete the site and copy all the wordpress files in again.
    The error I get is:
    500 – Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.

    I cannot seem to find a way to get Permalinks working on the windows site and further, everytime I try to tweak the Permalinks, I lose the site.

    I’m new to PHP and WordPress so I was hoping for simply instructions on how to fix this. The only resolutions I seem to be able to find are those involving the .htacess file which doesn’t apply for Windows servers.

    many thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Permalinks on IIS takes some additional effort (as opposed to most ‘nix systems).

    You may find some of this information valuable just a as a review checklist, to make sure that your IIS server is capable of “Pretty Permalink” use before you continue.

    Using Permalinks

    To paraphrase:

    “Pretty permalinks are available under:
    Apache web server with the mod_rewrite module
    Microsoft IIS 7+ web server with the URL Rewrite 1.1+ module and PHP 5 running as FastCGI
    Microsoft IIS 6+ using ASAPI_Rewrite
    Lighttpd using a 404 handler or mod_rewrite (see See Also) “

    Thanks Clayton, I’ll try. It’s a bit overwhelming to be honest and even just visiting the permalinks settings within the WordPress site breaks my site. I think things must be configured to enable Permalinks as my site sits under our main site which is using Permalinks and the main site works fine – but this was set up by a WordPress guru who has since moved on. I guess the hard thing is not knowing what he’s done in order to get it working.

    Hmmm, now at least I have an idea of what’s going on. My site is sitting in a subfolder of another wordpress site.
    Whenever I visit the Permalink Settings page, a web.config file is written. If I then view the site on the server, I get an error about a duplicate rule:

    Module: RewriteModule
    Notification: SendResponse
    Handler: StaticFile
    Error Code: 0x800700b7
    Config Error: Cannot add duplicate collection entry of type ‘rule’ with unique key attribute ‘name’ set to ‘wordpress’

    If I rename the rule, the site is at least functional. Perhaps with this in mind, I can at least start to work out why the pretty permalinks do not work, whereas the default do.

    If you have a windows server you should be able to login to it using IIS Remote Manager. If you can, then you can right click this sub-directory and click Deploy, then Convert to application.

    Converting the folder into an application will stop the duplication error, and treat that folder as a fresh website (and therefore not confuse WordPress, or IIS, with the Rewrite Module settings in the web.config files with the same names, hence giving this error).

    If you need quick instructions then post a reply and state what host/package you with to make sure you can do what I’m suggesting. If you have a VPS or your own dedicated server the chances are you already know what I’m talking about and you will definitely be able to do what I’m asking (as long as its IIS 7+, not sure if IIS 6 can remote login) 🙂

    @mamikel, if you have not yet found the instructions on how to correct the problem, see my instructions here:
    WordPress and Subdomains on a Windows Server

    Depending on your host, you may need to put the web.config file in your hosting root (as you are only allowed to host one site) or one in each root folder (if hosting multiple sites) – ask your host.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Permalinks for site hosted on Windows Server’ is closed to new replies.