WordPress.org

Forums

[resolved] Permalinks - error - The requested URL http:// was not found on this server (13 posts)

  1. febwa1976
    Member
    Posted 9 years ago #

    My site works really (standard Blix no plugins) well except when I try to add the permalink feature. I am using wordpress 1.5.2 and am hosted on a yahoo server. I have read the codex and note the .htaccess file comments. I dont know if these apply in my case but in any event I cannot find this file. I am a novice - any help appreciated. Thanks

  2. Kafkaesqui

    Posted 9 years ago #

    I cannot say for sure, but I don't believe Yahoo supports .htaccess and mod_rewrite. See this thread for more:

    http://wordpress.org/support/topic/33300

  3. febwa1976
    Member
    Posted 9 years ago #

    Strange. I have set filezilla to view hidden files and I cannot find .htaccess. I can however find it through my dashboard panel. Does this help me? Thanks

  4. Kafkaesqui

    Posted 9 years ago #

    I couldn't say, not having a Yahoo account. But it's very possible you have an .htaccess file yet the account is not given the proper permissions to alter it. You'd have to contact Yahoo for the definitive answer in that case.

  5. kickass
    Member
    Posted 9 years ago #

    With my hosting account I can only access and/or change .htaccess in the filemanager that comes with my cpanel for the account, so that's probably right. And, if that .htaccess file is located in your domain's root directory it isn't the right one (unless that's your main wordpress directory!). You have to MAKE another .htaccess file in your toplevel wordpress directory, and, if you do it like I did and edit it yourself, copy the .htaccess new info out of your wordpress admin area for the permalink structure and paste it into your newly created .htaccess in your wordpress directory.

    Oh geez, been there, done that. Hope this helps!

  6. febwa1976
    Member
    Posted 9 years ago #

    I just tried making a .htaccess file and Yahoo generates the following message: Filenames may only contain the characters 'a-z', 'A-Z', '0-9', '-', '_', and '.' and may not start with a '.' If you have another suggestion I would be happy to try it. Thanks.

  7. masquerade
    Member
    Posted 9 years ago #

    Get a better host is all you can really do.

  8. febwa1976
    Member
    Posted 9 years ago #

    For better of worse Yahoo hosts my current website, email systems etc and I have never had a problem with them.

    Is there another way? I am able to open my .htaccess file using the WordPress dashboard. Is there something I can modify in the file that could help me to get permalinks working.

    I have read http://codex.wordpress.org/Using_Permalinks#Editing_Rewrite_Rules_.28.htaccess.29 but am not sure this applies to me. I am anyhow running 1.5.2
    If any of you clever folk can help I would really appreciate it. Thanks

  9. kickass
    Member
    Posted 9 years ago #

    If the .htaccess file you want to edit is in your main wordpress directory, then yes, editing it will do the job. If it is not, then you need to create one in your main wordpress directory and edit that one. If you cannot create an .htaccess file in your main wordpress directory you need to move to a host that will allow you to do so OR you can stay with yahoo and forget about using permalinks.

  10. febwa1976
    Member
    Posted 9 years ago #

    I guess .htaccess is in the directory cause I can open through dashboard>manage>files. It is not however listed in my filemanager. In any event if I were to modify it my question is does anyone know how. The codex is really not clear to me.... Thanks

  11. kickass
    Member
    Posted 9 years ago #

    In WP admin, options/permalinks, when you do the permalinks creation in your admin area, if for any reason it can't overwrite your .htaccess file in your wordpress root file (ie, it doesn't exist and can't be overwritten or permissions are wrong) it will instead show a text box down at the bottom of the screen, with this above it: "If your .htaccess was writable we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all." Select all, then use your filemanager to create/edit the file and paste that stuff in there.

  12. febwa1976
    Member
    Posted 9 years ago #

    Thanks for taking the time on this. Here is what happens:
    I go to options>permalinks then enter the following
    /%year%/%monthnum%/%day%/%postname%/.
    I then get a message at the top of the page that says "permalink structure updated".
    I then go back to my site, and click on one of the posts. I then get the message "Not Found
    The requested URL http:// was not found on this server."
    Thanks

  13. febwa1976
    Member
    Posted 9 years ago #

    Problem Solved
    STUPID MISTAKE
    I added /index.php/ before the permalink structure and it now works perfectly.
    Thanks all for you time on this. I really appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags