WordPress.org

Support

Support » How-To and Troubleshooting » Permalinks don’t work – require index.php

Permalinks don’t work – require index.php

  • WordPress’ default options for custom permalinks aren’t working (selecting one returns a 404 error when following a link from the home page).

    However, if we do a custom path that includes “/index.php” then it works:
    /index.php/%year%/%monthnum%/%postname%/

    Any thoughts? .htaccess issue? Our tech guys aren’t being too helpful. Thanks!

Viewing 1 replies (of 1 total)
  • Those are called “almost pretty” permalinks — see more at the Permalinks page in the Codex.

    Have you confirmed that your host has mod_rewrite and AllowOverride properly on and enabled?

Viewing 1 replies (of 1 total)
  • The topic ‘Permalinks don’t work – require index.php’ is closed to new replies.
Skip to toolbar