WordPress.org

Forums

Permalinks Don't Work (15 posts)

  1. webwhat
    Member
    Posted 7 years ago #

    I use Yahoo Web Hosting. I installed wordpress correctly, and the normal post link structure works...

    http://www.domain.com/blog/?p=123

    But when I try to do...

    http://www.domain.com/blog/%postname%

    and click on the posts, it gives me this error...

    "The requested URL http:// was not found on this server."

    I did get this type of permalink structure to work...

    http://www.domain.com/blog/index.php/%postname%

    But thats it. Why do I need to put in the "index.php" part to make the permalinks work? I use to have an older version of wordpress installed, and the Permalinks worked just fine. How can I solve this problem?

  2. Chris_K
    Member
    Posted 7 years ago #

    How can I solve this problem?

    Change hosts.

    Yeah, I'm half serious. As I recall, with the version you get from Yahoo!, you have a special plugin to get permalinks to work their way. Do you still have that plugin and activated? If not, you're probably stuck with the "almost pretty" style you have going now.

    Search the forms here for "yahoo" for more excitement on the same topic.

  3. Maxaud
    Member
    Posted 7 years ago #

    I would suggest changing hosts but if that isn't an option, then maybe try the "Netfirms pretty permalink plugin"

    http://www.joelika.com/netfirms-pretty-permalinks

    Hope that helps!

  4. webwhat
    Member
    Posted 7 years ago #

    I tried that plugin, and unfortunately it did not work.

  5. webwhat
    Member
    Posted 7 years ago #

    Anyone have any other suggestions?

  6. nareshsays
    Member
    Posted 7 years ago #

    I have a locla installation of wordpress. Even after acticvating them in the settings I cant make them work. I am using the WP V2.5 now. I faced this earlier with V2.2 and couldnt activate it online too.

    Any help is appreciated. TIA.

  7. Non-default permalinks rely on Apache's mod_rewrite capabilities. Without Apache and mod_rewrite, you can't do "pretty" permalinks.

  8. thesmileyfreak
    Member
    Posted 7 years ago #

    I'm having the same problem with my permalinks. I'm using GoDaddy hosting, on Linux, which has mod_rewrite available to me, but I don't know anything about how to fix this.

    So...since I'm a n00b, can someone help me out on what exactly it is I need to do to make my links pretty? Please? :)

  9. moshu
    Member
    Posted 7 years ago #

    You can start by learning your own admin panel:
    Settings > Permalinks
    and the mandatory reading: Using_Permalinks

  10. watermelonkid
    Member
    Posted 6 years ago #

    why is everyone on this forum such a**holes? Dude asks a question, states that he's a noob, and that's your answer moshu? The reason he's asking the question is because the documentation sucks. I'm in the same position, and I have read all the settings, documentation, etc. Still not working, so we're using the forum for what it's for--asking questions when you've tried everything you know.

    Word to the wise for everyone--this forum is generally useless for help. Look elsewhere if you want to actually find people who can help. You will either find combative people here or get no answer at all generally.

  11. phejster
    Member
    Posted 6 years ago #

    @webwhat
    Are you putting "http://www.domain.com/blog/%postname%" in the permalinks field or just "/%postname%/"? If you putting the whole URL that could be causing the problems you're having.

  12. phejster
    Member
    Posted 6 years ago #

    @watermelonkid
    I would have to disagree with the sentiment that the forum is useless as I have learned quite a bit from the users here. As you pointed out, some people sadly require a certain level of effort from the 'asker' before helping out, whether that be having the 'asker' reading the documentation or Googling for answer.

    Hopefully my response to webwhat helps you as well.

  13. redbourn
    Member
    Posted 6 years ago #

    If you're using the latest version of wordpress then it has a bug and the techies are working on it.

    I changed from /%postname%/ to default and all the links came back again.

    Mike

  14. groundfresh
    Member
    Posted 6 years ago #

    I installed the latest version of WordPress, and suddenly /%postname%/ links dont work, AND the permalink Edit box under the Page title is GONE.

    So it's not a hosting issue, as another WordPress site I have installed on the host has an older version of WP, and the permalinks work just fine.. It's not an .htaccess issue for me either.

    Does anyone else have definitive WordPress info that the update is whats causing the problems?

    thanks,

    James

  15. groundfresh
    Member
    Posted 6 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic