Ready to get started?Download WordPress


Permalinks do not work. (3 posts)

  1. derfrosch
    Posted 2 years ago #

    I have installed WP on my computer using wamp but I can't seem to make the permalinks to work.
    My Htacces is this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wp/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wp/index.php [L]
    # END WordPress

    I have the rewrite_module on, and the AllowOverride set to all for everything except for this

    <Directory "c:/wamp/www/">
        # Possible values for the Options directive are "None", "All",
        # or any combination of:
        #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
        # Note that "MultiViews" must be named *explicitly* --- "Options All"
        # doesn't give it to you.
        # The Options directive is both complicated and important.  Please see
        # http://httpd.apache.org/docs/2.2/mod/core.html#options
        # for more information.
        Options None
        # AllowOverride controls what directives may be placed in .htaccess files.
        # It can be "All", "None", or any combination of the keywords:
        #   Options FileInfo AuthConfig Limit
        AllowOverride None
        # Controls who can get stuff from this server.
    #   onlineoffline tag - don't remove
        Order Deny,Allow
        Deny from all
        Allow from All

    If i set this to All i can't access my localhost.

  2. Kapil Chugh
    Posted 2 years ago #

    What error do you get when you set 'AllowOverride All'.

  3. pvashist75
    Posted 2 years ago #

    does it show any error when you turn on the permalinks?

Topic Closed

This topic has been closed to new replies.

About this Topic