Permalinks deny me access to my awstats folder (5 posts)

  1. tom_raftery
    Posted 11 years ago #

    I can't view the awstats folder on my site - this is because I'm publishing the site using WP 1.5 and it's mod_rewrite (created by the permalinks structure) won't let me into the awstats folder. Instead I get dropped into a 404 page.

    I tried accessing the folder using the ip address instead of the domain but couldn't get in - my ISP subsequently told me this wouldn't work - that I need to come in under my domain for awstats to function.

    I then tried to modify the .htaccess file by adding:
    RewriteCond %{REQUEST_URI} ^/icons/ [OR]
    RewriteCond %{REQUEST_URI} ^/images/ [OR]
    RewriteCond %{REQUEST_URI} ^/scripts/ [OR]
    RewriteCond %{REQUEST_URI} ^/cgi-bin/
    RewriteRule .* - [L]

    To tell it to ignore those folders in the following rules - but that didn't work either.

    Any ideas on how I can get this to work?

  2. tom_raftery
    Posted 11 years ago #


  3. tom_raftery
    Posted 11 years ago #


    I found a solution to this - in case anyone else has a similar problem in the future, if you add:

    RewriteCond %{REQUEST_URI} ^/awstats/
    RewriteRule ^.*$ - [L]

    to your .htaccess file above the WordPress inserted code, this will allow you view your Awstats folder


  4. MailGuard
    Posted 11 years ago #

    I am trying to get .htaccess going as well, do you have to have something in apache2.conf like the following relating to your root web directory?

    <Directory "/web_folder">
    Options X
    AllowOverride X
    Order deny, allow
    Allow from X

    And if so, what options do you require? I have been trying to get it working, but no matter what I put in .htaccess in the webroot, it was like it wasn't being looked at.


  5. tom_raftery
    Posted 11 years ago #


    I'm my site is being hosted by my ISP so I never get near the apache2.conf file!

    Good luck with it,


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.