Support » Fixing WordPress » Permalinks created but 404

  • Hello everyone. I’m hoping someone can help me out here because I’m stumped on a problem with permalinks on a blog I’m working on now. Here is what is happening:

    1)I do have mod_rewrite on my server, but I don’t know what version of apache I am running. I’m waiting on an email about that from my host.

    2)I have 2 other blogs set up on the same server with no permalink problems at all.

    3)I have tried to create the .htaccess manually, and by having it writable. Both to no avail.

    4)I want to use the permalink structure /%category%/%postname%/ .When I hover over the links, the status bar shows the links correctly, but when I click them, I get a 404 error. However, even though the links look like correct permalinks, I can still get to the page I want if I type in manually the ugly link with ?p=1, for example.

    5)I have tried with a variety of permalink structures and have the same issue, so I don’t know if it’s an issue with Apache and the /%category%/ . I have also tried the plugin which is supposed to rectify that bug, with no success.

    6)I have tried deleting and re-doing the .htaccess file, as well as deleting the entire install and db and starting fresh with no success either.

    I hope I have provided enough info for someone to point me in the right direction. As this is an adult oriented blog, not suitable for general audiences, I’ll refrain from posting the URL. Thanks in advance for any advice that my help me get this straightened out.

Viewing 6 replies - 1 through 6 (of 6 total)
  • What version of WP are you using?

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Just asking but is the wordpress/.htaccess file writeable? On my box, after I put in the new files from the tar.gz I did a ‘touch .htaccess’ in the wordpress directory and then ‘chown apache:apache .htaccess’ on the same file.

    I run the web server as the apache user. I updated the permalinks and all was well with the world.

    There have been problems with %category% in permalinks, I think if you run a search on this you might find the answer. I think you might also search on since I seem to remember some plugins there to deal with this issue- and that’s version 1.5.X, all of it.

    And I just have to ask, since it’s a mistake that CAN cause this- the .htaccess you’re modifying is the one in the WP root folder, right? Probably is since you’ve done this before, but it was worth mentioning.

    If you’re using 2.0 I have no clue.

    Sorry for not getting back to this thread sooner. I had a hard time finding it after the server move. Anyway, I’m using version 1.5.2 and Apache is 2.0.46 . Thanks for the plug in, kickass. I’ve read about the issue, but it’s possible that I tried the wrong plug in to fix it. The funny part is that I have the problem with any permalink structure, including tried and true formats that don’t use %category% at all. I’ll give it a shot with the plug in you recommend, and see what happens. And yes, it is the .htaccess in the root folder. That is where I have WP installed on this domain. Again, thank you all for your help. It’s much appreciated.

    Hmm, that plug in doesn’t seem to solve the problem either. I’ll keep digging for a solution. Thanks for the help everyone.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Permalinks created but 404’ is closed to new replies.