[resolved] Permalinks, comments, all not working (4 posts)

  1. tomwright
    Posted 10 years ago #

    Hi all,
    Problem: permalinks link to invalid page resulting in 404 error
    Comments same problem/error

    This is a new install, all automated, no manual meddling.
    Host: Bluehost
    url: http://www.wrightwing.net

    Yes, Bluehost supports and enables mod_rewrite by default
    I am waiting on my question about AllowOverride in the Apache httpd.conf file.

    Install was done to http://www.wrightwing.net/htmdir/WP

    .htaccess is in http://www.wrightwing.net/htmdir, this is where WP is creating it.

    index.html contains:
    Redirect permanent /index.html http://www.wrightwing.net/WP/index.php
    (note, the htmdir is invisible, and causes error if included in the redirect statement)

    My .htaccess file has been delted and recreated numerous time. Currently it contains:
    start .htaccess excerpt

    Redirect permanent /index.html http://www.wrightwing.net/WP/index.php
    RewriteEngine on
    RewriteCond %{HTTP_REFERER} !^http://wrightwing.net/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://wrightwing.net$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.wrightwing.net/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.wrightwing.net$ [NC]
    RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    .bunch of stuff generated by WP
    .RewriteRule ^archives/([0-9]{4})/?$ /index.php?year=$1 [QSA,L]

    # END WordPress

    end .htaccess excerpt

    I have tried the following permalink structures:

    They generate urls such as http://www.wrightwing.net/archives/2005/09/17/08/51/11/6/

    Which get a 404

    When selecting coments, a 404 is also generated by a URL such as:

    At this point I am at a complete loss. I have been through this support forum for days. I have tried many of the suggestions, none work.

    At this point, I am considering a complete reinstall, not using a separate directory fot WP, incase that is part of the problem.

    Oh, but press-it and post by email work, I tested but deleted the posts via the manage/posts page in the WP dashboard.

    Any clues?

    Thanks, Tom

  2. tomwright
    Posted 10 years ago #

    Since I had only 2 posts, I just deleted and re-installed. All works now.

    I think the problem was that the original install was done on the server BEFORE I was able to get my domain transferred to Bluehost. So I think some of the config files did not contain what they should have contained.
    So instead of slogging through all that php, I just reinstalled.

    HINT: Stay away from Earthlink and MelbourneIT. Slow, slow, slow response to requests. And Earthlink will not support the requirements of most blogging/CMS software.


  3. tincho
    Posted 10 years ago #

    so you deleted also the database and started a new one?
    I have a similar problem with the permalinks and get a 404 error

    in the main folder of my weblog (http://tincho.de) the permalinks and my google adsense dont work.

    when I copy the hole wordpress stuff and the database and run it under a seperate folder (http://tincho.de/test) all works fine...

    should I recreate the hole wp on the main folder??

    what do you think?

  4. tomwright
    Posted 10 years ago #

    I am new to this, so my opinion is worthless.

    Best to go through the other posts.

    My first install was done on the server using a numeric IP address and Unix paths to all the folders, but the URL is used in the new install, so something was just out of sync.


Topic Closed

This topic has been closed to new replies.

About this Topic