WordPress.org

Support

Support » How-To and Troubleshooting » Permalinks causing a headache!

Permalinks causing a headache!

  • Hi, i’m having problems with a page i’m making not showing up (404). I have read all the info on the codex page about permalinks and don’t usually have a problem with it. Same hosting so no rewrite issues that I know of. Some of the circumstances are new though;

    -The page that can’t be found is a parent of another page. Im doing this so I can populate the parent page with a loop of child pages.
    – The parent is a custom post type ( dont know if this holds any significance)
    – When I try a new custom permalink structure the page will then work, but when I make any other changes like adding a new page to the site the 404 appears again! Seems weird to me!

    My normal structure is /%category%/%postname%/

    If I turn the default on the page is found fine, but I dont want that because of SEO…

    Any guesses?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator t-p

    @t-p

    Hi, thanks for the link – I haven’t read that page before.

    I tried the details in the linked article ( take the htaccess file down, go in and set up permalinks again ), it didn’t work. Still only the default that’s working…. *head on desk*

    I also found a function (linked from that page you sent) written to sort out the 404’s with lots of positive feedback from users, that didn’t work either.

    Have I missed something else?

    Anyone had any problems like this and solved it?

    I have tried all sorts of different combos like /%category%/%postname%/ and /%postname%/ and /%category%/%postid%/ etc.

    Every time I make a new custom permalink I have never used before they work as expected. When I add any additional pages it all the parent/child page links break again. If I flush the permalinks nothing happens, and the custom permalink I set-up can’t be used again. If I set a new combination it works again, until I add or modify pages. Seems a weird problem to me.

    So far, only the default permalinks setting will work, which isn’t much use.

    Any help?

    Hate to keep going on about this but it’s not even close to being sorted. At the moment I think I will need to drop the parent/child relationship if it won’t work, and maybe use some custom meta boxes to parse the info instead. I’d rather this would just work though!

    Any advice? Please ; )

    Moderator t-p

    @t-p

    Try resetting your custom permalinks back to the default setting and deleting/renaming your WordPress .htaccess file. If that works, then try reading Using_Permalinks before setting a custom permalink structure again.

    Documentation: http://codex.wordpress.org/Using_Permalinks

    Hi, I will try this again later for the sake of it – but I have done all those steps several times already…it made not difference whatsoever 🙁

    I noticed the same problem: I tried turning a regular no-parent page into a child page and WordPress keeps redirecting all hyperlinks to it somewhere else!

    That only happens for that one page; all other similar pages were turned into child pages with no issues whatsoever. So I simply renamed the problem page’s URL/slug and magically everything’s all right again!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Permalinks causing a headache!’ is closed to new replies.
Skip to toolbar