Permalinks broken - Directs to 404 (8 posts)

  1. taddmencer
    Posted 7 years ago #

    Good morning WordPress community.

    I have an issue I hope someone will be able to aid me with.

    I've installed WordPress on an intranet in order to make a Wiki style knowledge base. Works fine. We're running a Fedora server (9 I believe) and so far so good. mod_rewrite is enabled and all the goodies as dictated in the codex.

    Strangely enough it ... well, just doesn't work.

    Whenever we do a simple permalink such as /%category%/%postname% it goes 404 - not WP 404 but server 404.

    Now, I can go pathinfo style ala index.php/%category%/%postname% and that works in general, however it won't allow for RSS or for accessing a post. All pages (parents and children) access perfectly fine.

    We are operating this site off a subdomain: lightbulb.ourdomainname.com/kb

    But I don't see how that would cause any problems.

    Here is our .htaccess information - basic WP stuff:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /kb/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /kb/index.php [L]

    So, I'm slightly confused here folks. I've cleared the permalinks countless times - logged in/out - viewed in different browsers - cleared cache ... nada.

    If you fine folks have any ideas, please let me know. It would be much appreciated.

  2. Roy
    Posted 7 years ago #

  3. taddmencer
    Posted 7 years ago #

    Nope, it's a fresh and clean install.

  4. Roy
    Posted 7 years ago #

    The bottom line is, you can't use /index.php/ in 2.6. Read the post that I linked to.

  5. taddmencer
    Posted 7 years ago #

    Ok, that's all well and good - but I dont' really WANT to use the pathinfo. It DOES work to an extent - but it's not what I'm aiming for.

    I want to use standard prettylinks:

    That's what I want to see. But it 404s every time.

  6. Roy
    Posted 7 years ago #

    Also without /index.php/ in the permalink? Then it becomes an entirely different subject. That's above my head (too). But perhaps you can search a little through the forums, "codex" or use Google.
    Here's a thread that links the phenomenon to a server setting. It could be something with mod_rewrite. There's more to look into now I'm afraid.

  7. taddmencer
    Posted 7 years ago #

    Yeah I know - different monsters. We've gone through just about every setting, reset the server, changed this and that ... it's weird and quite frustrating to say the least!

  8. taddmencer
    Posted 7 years ago #

    I did this - http://wordpress.org/support/topic/189058?replies=1 and that worked, yes using the index.php method, but hey .. I'll try anything to get this thing running and off my plate at this point!

Topic Closed

This topic has been closed to new replies.

About this Topic