Support » Fixing WordPress » Permalinks broken after server move

  • I moved servers and now the permalinks don’t work anymore. They all throw a 404 Not-found error. I tried resetting them (e.g. set them to ?p=123, then back to /%postname%/), with all plugins disabled on the default theme with no luck.
    I’ve checked the .htaccess file, it’s the same as described everywhere online.
    The base URL works but all redirects are broken.
    I’ve checked the apache modules, they seem to all be enabled, as seen in the following list of enabled modules:

    # apache2ctl -M
    Loaded Modules:
     core_module (static)
     so_module (static)
     watchdog_module (static)
     http_module (static)
     log_config_module (static)
     logio_module (static)
     version_module (static)
     unixd_module (static)
     access_compat_module (shared)
     alias_module (shared)
     auth_basic_module (shared)
     authn_core_module (shared)
     authn_file_module (shared)
     authz_core_module (shared)
     authz_host_module (shared)
     authz_user_module (shared)
     autoindex_module (shared)
     deflate_module (shared)
     dir_module (shared)
     env_module (shared)
     expires_module (shared)
     filter_module (shared)
     headers_module (shared)
     include_module (shared)
     mime_module (shared)
     mpm_prefork_module (shared)
     negotiation_module (shared)
     php5_module (shared)
     proxy_module (shared)
     proxy_http_module (shared)
     rewrite_module (shared)
     setenvif_module (shared)
     status_module (shared)

    I googled for hours, only to find out everything seems to be configured correctly. What am I missing?
    URL is http://blog.lolmewn.nl/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator t-p

    (@t-p)

    does the default setting work?

    Yes, putting it to ?p=123 works. Makes sense since it doesn’t use redirects but simply uses the index.php. /%postname%/ doesn’t work though, which is what I’m trying to get (and is what I had before).

    Moderator t-p

    (@t-p)

    If that works, then try reading Using_Permalinks before setting a custom permalink structure again. If clearing your Permalinks does not alleviate the issue, this could be attributed to anything from a web server configuration to a bad WordPress install

    Hey Tara, thanks for your reply.
    I just reinstalled WordPress (twice) and that did not seem to help at all. Guess that rules out the bad wordpress install.
    I checked out your link but am unsure what can be wrong; mod_rewrite is enabled. Any guesses? I’m unsure how to check for FollowSymLinks. Should I post my apache sites-enabled files?
    For now I’ve changed the permalinks structure to be prefixed by index.php as to have a working blog while the problem remains persistent.

    Moderator t-p

    (@t-p)

    So what was the solution?
    It’s so disappointing when a users asks a question in public, but does not update with the solution to their problem.

    I never found a solution.

    I had your same problem after moving to a new deployment. Here was the solution: http://stackoverflow.com/questions/18740419/how-to-set-allowoverride-all

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Permalinks broken after server move’ is closed to new replies.