Permalinks broken after moving from Virtual Host to Root dir (4 posts)

  1. gawehner@gmail.com
    Posted 5 years ago #

    So, I had built a virtual host with ISPConfig - my path (linux) was /var/www/clients/client1/web1/web/. There was also a link in the root dir /var/www/www.zombie.dnsdojo.org -> /var/www/clients/client1/web1/web/.

    web/ contained all of my wordpress files and the index.php and .htaccess files. What I did is go to the WordPress Admin panel and make sure that the WordPress address and Blog address were correct. Since my root domain is also http://www.zombie.dnsdojo.org, the site address wasn't changing. I also went into Misc and checked the permalinks address - still http://www.zombie.dnsdojo.org/year/month/content. I then moved all of my wordpress content to /var/www and removed the clients and virtual hosts. This was a mistake, I know, but it's done. I should have left everything else up until I got the site running in root. Also, I accidentally deleted my .htaccess file since 'mv * /var/www' didn't move hidden files.

    So I rebuilt the .htaccess files with from the permalinks page, and can currently navigate to the landing page. I can also get into the admin site. However, every one of my links gives me an Object not Found error. Pages, tags, categories, posts - all broken. I can see content on the landing page, even play embedded video, but no navigation.

    I've been around and around trying to figure it out, but I'm at a loss. I'm using mysql 5 and have full access to the server. Any suggestions? I was planning on upgrading to 3.0.1, so if this would help in the fix, I'm up for it. Thanks in advance!

  2. gawehner@gmail.com
    Posted 5 years ago #

    I just published a new link. It's a simple text post. I could preview the post, and it shows up on my main page, but still no navigation to the wp-content/upload/2010/09 directory.


  3. Rev. Voodoo
    Volunteer Moderator
    Posted 5 years ago #

    but still no navigation to the wp-content/upload/2010/09

    settings->media upload path, have you checked that?

  4. gawehner@gmail.com
    Posted 5 years ago #

    upload path is set to wp-content/uploads.

    Most of the upload sub-directories are empty - even though I have posts from the missing months. However, most of those posts are html code of embedded video. Just to double check - I went to a post that had content in upload, a photo that was on my server. That post also didn't work. Is this a settings problem or a database issue?

Topic Closed

This topic has been closed to new replies.

About this Topic