Support » Fixing WordPress » Permalinks – at my wits end

  • Hi,

    I just installed wordpress 2.7 (and upgraded to 2.7) and I am having a heck of a time with permalinks.

    When I change the permalink style, I get the following errors

    Not Found
    The requested URL /2009/02/hello-world/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.33 Server at Port 80

    I use godaddy for hosting. I have set up wordpress within this hosting account before and not had a problem like this. This is the first time I am working with 2.7.

    WordPress indicates to me that the permalink structure has been changed (no .htaccess writing error). Just in case, I had changed the permissions of .htaccess to 777 on a temporary basis, and that did not do anything either.

    I’ve basically run out of ideas. I’ve searched on here and the codex and google and not found any applicable solutions.

    I am running wordpress from the root hosting directory. My last attempt for the night is going to be to put it into a subdirectory and see if that works.

    Any suggestions are welcome.

    I am using php5 and the mysql database is 4.1.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Ok, it looks like moving it to a hosting subidrectory worked.

    The question is why do permalinks not work from within the root directory of godaddy hosting?

    Anyone with experience with this?

    I used to use Godaddy for hosting. The reason you get a 404 when you change permalinks is because changing permalinks changes the .htaccess file and with Godaddy, when you change the .htaccess, it can take up to an hour or so to update. Meanwhile your links come up as 404’s. Just change them to what you want and wait.

    I don’t find this to be true. If I put the install in a subdirectory and change permalinks, the changes are reflected immediately. The problem is changing permalinks in a root hosting directory install .

    The problem is changing permalinks in a root hosting directory install .

    and as thisisedie stated this is a problem peculiar to godaddy for root installs

    Also, make sure you add the AllowOverride options to the directory in httpd.conf

    Hope that helps.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Permalinks – at my wits end’ is closed to new replies.