Permalinks and UTF-8 (4 posts)

  1. earcos
    Posted 11 years ago #

    I've have imported all my entries from MT to WordPrees, I am using the following structure for permalinks:
    I have found a way of using underscores (_) instead of dashes (-) but I can't seem to find a way of replacing letters with accents like á, é, í, ó, ú to a, e, i, o u.
    I am using UTF-8 for the weblog encoding and that seems to be the problem. Right now WordPress is doing the following:
    If I have a title called: "Sentado en un camión" wordpress generates this:
    And I need something like: "sentado_en_un_camion"
    Any pointers or ideas?
    Thanks a lot in advance.

  2. moshu
    Posted 11 years ago #

    You may try this plugin http://wiki.wordpress.org/UrlencodedPermalinks
    I didn't use it, but I remember many WP users complaining about not being able to use non-English characters in the title. It seems to be an (ethnocentric) error in coding :)
    But there is hope - I've read a promise that said it will be fixed in 1.3.

  3. serendipity
    Posted 11 years ago #

    It is in 1.3 ... I seem to remember another hack/plugin that replaces accented characters with the unaccented equivalent. But I can't find it right now.

  4. earcos
    Posted 11 years ago #

    In fact I am trying 1.3 alpha 4 right now and have the same problem, but...it's alpha so I guess it haven't been implemented yet :-)

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.