WordPress.org

Support

Support » Alpha/Beta » [Resolved] Permalinks and Edit posts WP 2.0 beta

[Resolved] Permalinks and Edit posts WP 2.0 beta

  • I have downloaded and installed the beta 2.0 version of WP. I have it running at http://wpbeta.aleeya.net/

    When I change the permalink structure to

    Date and name based
    » http://wpbeta.aleeya.net/2005/11/19/sample-post/

    It breaks all of the links. I reverted back to the

    Default
    » http://wpbeta.aleeya.net/?p=123

    and it worked fine again.
    I checked the .htaccess and even chmodded it to 666, but for some reason, it is not updating when I click on the “update permalink structure”.

    I do not have any plugins enabled. This is a defualt installation with no tweaks. I renamed the default category to the category for this post. This is the first post on the site.

    Along with that, I noticed that my link opened in the same window. I went back and edited the post for the link to open in a new window. It did not work. The HTML shows before when I click on the HTML link where the post is entered. I also tried to add manually target="_blank" manually, but it did not update either. I have the same problem if I use longdesc="Long description tag" , but Any other edits will save.

    Has anyone else noticed similar things?

Viewing 15 replies - 1 through 15 (of 49 total)
  • I always change .htaccess to 777 before I ask wp to write to it, then set it back to 644. I’m using the same thing you tried, date and name based, and it worked (and is working) fine for me.

    Hmm. I’ve always had the permalinks when clicked on open in the same window, didn’t realize people would think that problematic. I hate sites where stuff like that opens in a new window….

    I should have been more specific on the link opening in a new window. That one is not a perma link, but a link in the post itself to an external website. I was trying to get it to open in a new window. I prefer to have pages on my site open in the same window and anything external opening in a new window where possible.

    I tried changing the chmod to 777, it did not work. I checked permissions and it is owned by me as well, so everything is right on permissions. I tried all the different permalinks to choose from, it still did not work. I even tried changing permalinks and then saveing a nd publishing a new post, no go.

    I will try editing the .htaccess by hand and see what that does. No matter what I cahnge the .htaccess to or the permalinks too, it does not change the .htaccess file.

    The timestamp will change on the .htaccess file, but the contents of the file do not change – which I assume it should?

    This exact thing is happening to me on WP 1.5.2 I’m new and thought I was crazy and missing something. I have 2 different tutorials one for if mod write is not on server. My host support has verified it active. The other tutorial says just cut and paste. I am trying the same format as you, (ideally) but can get none but default to work. Will try shutting down firewalls next.

    I noticed on my install that I was getting 404’s, when I clicked on post. I went into the Options->Permalinks, and resaved the permalinks, and all was well.

    Have you tried deleting the .htaccess?

    When I tried to resave permalinks as a differnt one (instead of default) it would give me 404’s when I clicked on them, so I had to revert back to default. I ahve not tried deleting the .htaccess, but I will try that thanks!

    ———–
    I deleted the .htaccess and resafved permalinks..
    resaved permalinks.. it still does not work. permissions are 777 and owner is me, same as rest of directory…

    I also tried availble options the default, saved, then back to the one I wanted to chose and saved

    I clicked on one of the available options, then back to custom, then saved. Just for reference.

    no matter which option for permalink i choose, it has the same entry in .htaccess

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>

    is that correct? Just to veryify, I deleted it again, and set the permissions to read only. so, when I cahnged permalink structure, it will not write and the bottom of the options/permalinks page tells me

    If your .htaccess was writable we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    which is fine, thats what I wanted at this time to check this… and in the box, no matter what structure option I choose it still only presents

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>

    on all the options. Shouldn’t the rewrite options change based on teh structure I choose?

    There’s some issues, for sure. I just did some testing, and deleted the .htaccess, placed a clean file and played around with different permalinks. It says updating permalinks, but nothing is writing to the .htaccess file, only the default permalinks will work. It’s simply not writing the .htaccess. I must have accidently used one of the default when I changed the permalinks earlier.
    I’d call it a bug.

    estjohn’s contents there is exactly what’s shown in my .htaccess; this is a permalink from my test install:

    http://netwizardry.net/nightwiz/2005/11/17/night-at-the-wizards-bit/

    So it’s working properly on mine…. I have to say I was surprised, simply because I’ve had a lot of trouble overall with permalinks, with 1.5+ versions.

    vkaryl lol.. I had just the opposite.. none with 1.5..
    vkaryl if you delete the .htaccess and then start with a new one does it still work properly for you via the steps I wrote above?

    *laughing* I haven’t checked, because you see if it ain’t broke don’t fix it!

    I was going to set up a second testsite anyway, so will do so and see what happens….

    thanks 🙂 I appreciate your alls help with all this! This new test one I am doing is nothing criticial.. so I am not in any hurry or anything.

    vkaryl, can you change the permalinks to something like /%year%/%category%/%postname%/ and everything work?

    Ayup. Here’s what I did just now:

    1. Changed the .htaccess file permissions through my ftp client to 777.
    2. Accessed the site admin permalinks section.
    3. Input in Custom what I copied direct from miklb’s post above.
    4. Clicked the Update button.
    5. Got the Permalinks updated message.
    6. Accessed the blog, which loaded just fine; copied the permalinks link location, see here: http://netwizardry.net/nightwiz/2005/general/night-at-the-wizards-bit/
    7. Changed .htaccess permissions back to 644 through ftp client.

    Test site in place here: http://netwizardry.net/nightwiz/

    did your .htaccess already have /%year%/%category%/%postname%/ in it to begin with when you did that? That is why I was curious if you deleted the file completely, and then WP creted a new .htaccess when saving, if it would contain the same info. If it is already in there, it might change the timestamp, but no content in it is being changed..

    I took the exact steps you said above and it did not change anything.. hmmm.

Viewing 15 replies - 1 through 15 (of 49 total)
  • The topic ‘[Resolved] Permalinks and Edit posts WP 2.0 beta’ is closed to new replies.