Ready to get started?Download WordPress


[resolved] permalinks and database errors (6 posts)

  1. npredford
    Posted 7 years ago #


    I attempted to update the Permalinks structure on this blog:


    I tried the CUSTOM ans set it to


    However after testing the blog links the categories showed an 404 error page so
    I tried other variations after reading the codex for Troubleshooting:

    I decided to return back to the default but now I get database error on the


    WordPress database error: [Table 'beyblade_wordpress.wp_post2cat' doesn't exist]
    SELECT SQL_CALC_FOUND_ROWS wp_posts.* FROM wp_posts LEFT JOIN wp_post2cat ON (wp_posts.ID = wp_post2cat.post_id) WHERE 1=1 AND wp_post2cat.category_id IN (1, 10) AND (post_type = 'post' AND (post_status = 'publish')) GROUP BY wp_posts.ID ORDER BY post_date DESC LIMIT 0, 10

    Fatal error: Call to undefined function is_tag() in /home/beyblade/public_html/blog/wp-includes/template-loader.php on line 38

    Fatal error: Call to undefined function is_tag() in /home/beyblade/public_html/blog/wp-includes/template-loader.php on line 38
    Would appreciate your advice and solution to restore the blog links.

  2. moshu
    Posted 7 years ago #

    For the first error see the sticky post on the main page of the forum!

  3. npredford
    Posted 7 years ago #

    Thanks for the reply.

    I have read that topic but my WP 2.3 install was done over two weeks ago. I have the latest plugins such as Google XML Sitemaps 3.0 which works fine.

    My errors came after testing out the Permalink structure.

    I have tried => Date and name based option
    and left the Optional categories blank.

    I did note that each time I clicked on the Update Permalink that the screen goes white and show the following message:

    Fatal error: Call to undefined method WP_Rewrite::set_tag_base() in /home/beyblade/public_html/blog/wp-admin/options-permalink.php on line 81

    I haven't changed anything else. Do you have any suggestions?

  4. moshu
    Posted 7 years ago #

    Sounds like some corrupted (not completely uploaded) files during the upgrade...

  5. npredford
    Posted 7 years ago #

    I have re-uploaded the file but there is no change. I've also reverted back to the Default Permalink but there are still errors.

    I have a back up but am not familiar with install instructions.

    Would you suggest I reinstall the previous back up?

    I would appreciate it if someone experienced could assist me with this.

  6. npredford
    Posted 7 years ago #

    I reuploaded the wp-includes once more and EMPTIED my CACHE. Now things are back to normal.

    Thanks for your advice moshu


Topic Closed

This topic has been closed to new replies.

About this Topic