Support » Fixing WordPress » Permalinks 404 on LAMP (have read up & tried everything)

  • Resolved tysontra


    I realize there are a million threads on this same topic, and I think I’ve read most of them and tried just about everything. I’m running the latest version of WordPress (with this theme) on LAMP, using Ubuntu 11 on EC2 with Elastic IP and GoDaddy DNS. I’ve spent much more time on an IIS/Windows stack, so I’m learning on the fly here. When I try to update permalinks and I visit any of my posts I get something like the following:

    Not Found

    The requested URL /2012/06/my-article-title/ was not found on this server.
    Apache/2.2.20 (Ubuntu) Server at Port 80

    I have the Advanced Permalinks plugin (for link migration), but I’ve tried both with and without and I get the same error either way. I’ve got WordPress in it’s own directory under /var/www/foo. Theres an .htaccess file under /var/www, and I verified that when I update the Permalink setting via the Dashboard it changes from empty to the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Note that this file is in /var/www and not the /var/www/foo directory, but from what I’ve read that is where it should be. I’ve tried adding both of the following to apache2.conf (since Ubuntu seems to keep settings there by convention from what I’ve read, httpd.conf is empty):

    <Directory />
    Options FollowSymLinks
    AllowOverride All

    I’ve also tried specifying /var/www/foo in the directory node. I’m not really sure what else to try. Thanks in advance for any help, I really appreciate it!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Quick ping on this. Would really appreciate help, I’m dead stuck. Thanks!

    The Rewrite Module must be up and configured properly to use mod rewrite. A plugin is not required.

    As far as I can tell, I have the Rewrite Module up. I followed these instructions. If I type “sudo a2enmod” followed by “rewrite” I get “Module rewrite already enabled”. I’m not sure what you mean by being correctly configuring the module, the configs that I’ve played with in both .htaccess and apache2.conf/httpd.conf are above. If I’m missing anything else, please let me know. Really appreciate you taking the time to respond!

    Got it. Had “AllowOverride None” hidden under /etc/apache2/sites-available/default. This was the money thread. Blog is up and running with pretty permalinks, thanks for the help all!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Permalinks 404 on LAMP (have read up & tried everything)’ is closed to new replies.