Support » Fixing WordPress » Permalinks. 404 errors

  • Hi everyone.

    I’m having a bit of a problem setting up pretty permalinks on my LAMP server. Its Ubuntu 12.04 with apache2 btw. I think apache is set up correctly for mod_rewrite but not sure. Latest WP version.

    I have WordPress permalinks set to Custom structure : /%category%/%postname%

    When I hover over a link to a post I get a sensible looking link. ie :- but this throws up a 404 when clicked.
    The post was generated before I changed the permalinks setting in wordpress and set up apache to use mod_rewrite. Not sure if this matters though.

    Really I need some advice on how to start tracking down the problem.

    I have access to all files for wordpress and apache configuration/virtual host configs etc.
    I think the host files are correct but not sure.
    I generated my own .htaccess file from the one on the wordpress codex.

    Any advice would be most welcome.



Viewing 9 replies - 1 through 9 (of 9 total)
  • Might want to have each post be in a category when using that permalink setting. Just use /%postname%/ and a good theme/plugins.


    Thanks for the reply. I have placed that post in a catagory but still seem to get the 404 error. I assume the mod_rewrite is working on the apache side of things though….
    I have also changed the permalink setting to /%postname%/ as suggested with the same 404 error.

    Not sure how the theme or plugins affect things. Could you elaborate ?



    The sailboat is blue with grey sails. Are you a bot? If not divide 21 by 3. Answer without numbers.

    Sounds like a nice boat.
    Thats seven btw.
    me < confused……..

    A bot is an automated computer/server. Typically they dole out spam or malware. So Robs Bots is human?

    What server cache/CDN is in use?

    Bots are getting pretty good if I can be mistaken for one.
    Or maybe I’m not a bright as I thought I was…. 🙂

    Definately human, or close anyway.

    Not sure what you mean by server cache/CDN. Where can I find this info ?



    Just had a quick google on cache and CDN. I just have a single virtual machine serving up pages from a couples of small sites, all run off of apache2 with some virtual servers set up in the host files. Not sure there is any caching. Its straight from the server I think.

    Does this answer your question ?



    Just thought I should mention. The only thing in my .htaccess file is the code from the wp codex.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    I created this file. Should there be anything else in there ?

    I’ve this issue for along, and tried hard to fix it with googling, finally I found that I have to enable “rewrite_module” on apache where I installed it at WAMP server, and now everything work well !!

    Try to enable the “rewrite_module” and let us know what happen after that 😉

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Permalinks. 404 errors’ is closed to new replies.