Support » Installing WordPress » Day and name Permalinks results in 404 error

  • Having difficulties with Permalinks in 2.7.

    I have fresh installation of both 2.6.5 and 2.7 on a single domain. 2.6.5 in directory ‘wp6’ and 2.7 in directory ‘wp7’. Each on its own separate database. No plugins, themes, etc. I logged in the 2.6.5 installation, enabled permalinks, got code for the .htaccess and created the .htaccess file in the ‘wp6’ directory. 2.6.5 works great!!

    I did the same thing for 2.7, except put the 2.7 .htaccess code in the ‘wp7’ directory and when I try to click on a link, it gives me “Error 404 – Not Found”.

    Any thoughts as to what is going on?

Viewing 15 replies - 46 through 60 (of 60 total)
  • Nope I haven’t, I’ve just been busy adding pages and writing content for my site and constantly changing the string in phpmyadmin. Perhaps there’s a configuration in apache that’s messing us up?

    Well, that’s what I’m thinking, so I’ll send in a ticket later today. If you don’t mind putting it up here, what’s your domain name so I can include it in the ticket? If you’d rather do it privately, send me an email at gabe AT ghscommunications DOT com

    so, any news?

    I am using Anhosting as well and have exactly the same problem. I dont know what to do i have searched everywhere and done everything.

    I was finally able to get my blog working by using this:

    php_flag magic_quotes_gpc Off

    Overall it looks like this

    php_flag magic_quotes_gpc Off
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Hopefully this will work for some of you. It worked for me finally!

    I submitted a ticket and they wrote back saying they could not produce the error on their end. Sure enough, when I tried going back and doing it on any of my existing blogs or a clean install, I was unable to reproduce the error. All pretty permalinks are now working across my account. So something changed, I’m not sure.

    However, WordPress loads are still pretty slow, especially in peak times – this is with SuperCache installed and activated. I may submit a ticket to them about that fairly soon.

    Still Nothing from me. I dont know what else to do.

    Hello,

    We have tried to change the “Permalink Settings” as per your request.
    When we change the settings, it is taking effect also. The new redirection
    values are written to .htaccess file. But there is no data in that redirected
    place currently. Could you pleas check with the WordPress support regarding
    this matter.

    Currently we have reverted back the changes to default.

    ***********************
    root@ans70 [/home/qualgia4/public_html]# cat .htaccess
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress
    root@ans70 [/home/qualgia4/public_html]# find . -name “2009”
    root@ans70 [/home/qualgia4/public_html]#
    **********************************

    In case you have any more queries, please don’t hesitate to contact us with
    all the required details. We’ll be happy to assist you further.


    Regards,
    Thomas M
    Technical Support Representative.
    Hosting Services Inc

    Helping out a friend with this issue on shared hosting (Anhosting) this is the solution we arrived at :

    I tried one more thing. It seems Anhosting allows changing some PHP variables by adding a PHP.INI file to the directory in question (http://help.midphase.com/support/questions.php?questionid=527) so I added a PHP.INI file with the following directive :
    magic_quotes_gpc = Off

    I created a new entry, and it was posted okay, so I’m guessing this problem is now solved. Let me know if you realize otherwise.

    Yup, that seems to have done the trick for me. As I mentioned, I was no longer experiencing permalink issues, but the install was extremely slow, which was a symptom others had mentioned. Adding the php.ini file seems to have dramatically sped up the load times of the installation.

    I’m hosted at anhosting, and it seems that the problem has magically dissapeared. i can now edit pages without getting 404s. not sure if i can still edit pages, but since i’ve launched my site im not going to mess around with it anymore.

    Yep! I’m also with AN Hosting and the problem has magically disappeared for me too. Basetwo: I also edited my “About page” with no problems.

    I tried all of the solutions posted here and none of them worked. What finally fixed it was two things. Please keep in mind that this is with a self-installed Ubuntu 8.10 server running LAMP

    1. Having AllowOveride set to all in my virtual host config
    2. And running the following command sudo a2enmod rewrite

    That command was found Here

    We host our WordPress installation using Redhat linux and apache. Our host is a virtual host.

    In order to get Permalinks to behave properly, we have to add:
    RewriteOptions Inherit

    to our .htaccess file, in addition to the items which WordPress wrote. We also made sure that
    RewriteEngine On
    was there.

    Documentation for mod_rewrite mentions the need for the “Inherit” option, which is NOT set by default:
    http://httpd.apache.org/docs/2.2/mod/mod_rewrite.html

    Note that if you wish, you can add
    RewriteEngine On
    RewriteOptions Inherit
    inside the virtual host block in your httpd.conf

    Hope that helps someone!
    John

    This problem (which I just ran into myself) is that the Apache config file is not allowing certain things to be controlled by .htaccess. Somewhere in httpd.conf you will find a line like:

    AllowOverride None

    That specifies which options the .htaccess file is allowed to use. The Rewrite module requires use of the FileInfo module. So in the entry for your host’s directory, you need something that looks like.

    AllowOverride FileInfo

    Make that change, and the new PermaLinks will work just fine.

    More specifically, here’s a complete example.

    <VirtualHost *:80>
        DocumentRoot "/usr/local/www/somewherefilms.com"
        ServerName somewherefilms.com
        ServerAlias www.somewherefilms.com
        ErrorLog "/usr/local/www/logs/somewherefilms.com-error_log"
        CustomLog "/usr/local/www/logs/somewherefilms.com-access_log" common
        <Directory />
            Order deny,allow
            AllowOverride FileInfo
        </Directory>
    </VirtualHost>

    If you can’t get your ISP to add FileInfo to AllowOverride, then you’re pretty much stuck.

Viewing 15 replies - 46 through 60 (of 60 total)
  • The topic ‘Day and name Permalinks results in 404 error’ is closed to new replies.