WordPress.org

Forums

Permalink/.htaccess problems - can't get rid of index.php (12 posts)

  1. 3stripe
    Member
    Posted 9 years ago #

    Hi folks,

    I'v never had problems with permalinks before... but having big ones with WP2.02, can anyone help me? I've tried everything I can think of to fix this, short of re-installing from scratch.

    Blog address: "/jotter" from the root directory
    Custom structure: "/%year%/%postname%/"

    On updating my permalinks I'm told "You should update your .htaccess now", however my .htaccess file is there and chmodded to 777. Nothing seems to be added to it ever.

    In summary, I can only view my blog in the jotter directory when I view /index.php/jotter... similarly for static pages I have to put index.php/ before them as well...

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /jotter/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /jotter/index.php [L]
    </IfModule>

    Any suggestions?

    Thanks for your time,

    3stripe
    (URL in question is http://tinyurl.com/p9zt7)

  2. 3stripe
    Member
    Posted 9 years ago #

    (I should also mention that I've double checked that mod rewrite is active on my hosting)

  3. 3stripe
    Member
    Posted 9 years ago #

    Just had word back from the hosting company, they can't see anything wrong on their side... so... wonder what I've missed.. hmmm

  4. 3stripe
    Member
    Posted 9 years ago #

    Another plea for help. Totally stuck on this one! Need a kind soul who knows how to sort this :-(

  5. 3stripe
    Member
    Posted 9 years ago #

    Helloooooooooooo

    Since this forum was updated (and the search function changed), it's really hard to find stuff on here, or get any assistance.

    Yes I know most of you are probably just really busy and that's cool, cos I know everyone has their own stuff to work on... and this isn't that big a problem at the end of the day

    Can I get help from anyone on this?

  6. maerk
    Member
    Posted 9 years ago #

    Add the new code to your .htaccess manually.

    And you really shouldn't have your .htaccess set to 777, it's not safe.

  7. 3stripe
    Member
    Posted 9 years ago #

    Thanks for the suggestion :-)

    I just copied and pasted in the .htaccess code

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /jotter/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /jotter/index.php [L]
    </IfModule>

    Now I'm getting a 500 Internal Server Error!?

  8. maerk
    Member
    Posted 9 years ago #

    Maybe it's creating the file? Check to see if the permalinks work now.

  9. 3stripe
    Member
    Posted 9 years ago #

    Fixed it - by copying .htacces from another install of WordPress... and then changing the permalink options in Admin... somehow this has fixed it all, thanks again :)

  10. maerk
    Member
    Posted 9 years ago #

    Thanks for saying thanks ;)

  11. 3stripe
    Member
    Posted 9 years ago #

    Thanks for saying thanks for saying thanks :-P

    Now I have a new problem... my static front page is showing on the homepage, and the subdirectory that I've set as the actual folder for the blog...

    http://www.paulryding.com/index.php/
    http://www.paulryding.com/jotter/

    Hmmm

  12. maerk
    Member
    Posted 9 years ago #

    I had a similar problem a while ago, to do with the RewriteBase directive.

    Even if it's not that, you need to make sure that the .htaccess is correct. Download the .htaccess file to your computer. Then, go into the permalinks option page and make sure the options are what you want. Open your .htaccess and delete the wordpress-generated stuff, and replace it with the code that the page gives you.

    Sorry, that's a bit complicated. Basically, the permalinks page will give you some code that you need to manually insert into the .htaccess. Don't let it insert it for you!

Topic Closed

This topic has been closed to new replies.

About this Topic