WordPress.org

Forums

Permalink writing in .htaccess causes 403 error (6 posts)

  1. steinhaeuser
    Member
    Posted 9 years ago #

    Dear friends of WP,

    I tried again to get the configurable permalink writing of the
    links running on my weg pages. However, once the .htaccess with all
    rights set (777) was empty an in place, everything was running.

    Now I let WP write the syntax suggested in the file, see
    http://www.die-steinhaeuser.de/wordpress/test.htaccess and my web pages don't show up again. Instead of this you are shown the 403 access denied page.

    What is wrong with my way of doing it?

    Thanks for being help for me!

    CU, Steffen

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Delete what is in there, and try this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php
    </IfModule>

    # END WordPress

    also, a .htaccess file should be 666 or less, never 777 as this is risky.

  3. DavidMeade
    Member
    Posted 9 years ago #

    That's exactly that I have in mine and I get 404 errors if I use anything but the default structure, and category based urls dont work at all.

    :-((

  4. DavidMeade
    Member
    Posted 9 years ago #

    I should also note that I've just realized it SEEMS to be that only categories that contain the string 'blog' are failing (such as 'blog', 'audio blog', 'video blog', etc). They get 404s. but categories that do not contain the string blog seem to work ok.

    Also the .htaccess file never gets changed by wordpress...should it? WordPress seems to tack on some blank lines, but it never changes the content above.

  5. steinhaeuser
    Member
    Posted 9 years ago #

    Thanks podz,

    I've tried it, but it didn't work. The message of the 403 error is as follows:


    Forbidden
    You don't have permission to access /wordpress/ on this server.

    -------------------------------------------------------

    Apache/1.3.26 Server at www.die-steinhaeuser.de Port 80

    Maybe the configuration of the web space or the root is wrong. My web pages are not in the root of the web, but in the sub-dir /wordpress/.

    Any hint?

    CU, Steffen

  6. dwhs
    Member
    Posted 8 years ago #

    In addition to what podz gives above, you may need:

    Options +FollowSymLinks

    That fixed the problem for me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags