WordPress.org

Forums

Permalink Structure with .html after post name (4 posts)

  1. dshah
    Member
    Posted 9 years ago #

    Hi,

    I am trying to achieve the URL to look like

    http://www.mysite.com/year/month/post_name.html by updating the Permalink Structure.

    On my site I have modified the structure to /%year%/%monthnum%/%postname%.html

    After this I see that some pages work just fine, but most of pages show bare content text (no theme decorations).

    e.g Following page on my site (http://www.indianuncle.com/wp/) looks just fine

    http://www.indianuncle.com/wp/2005/10/gulshan-grover-to-act-in-next-james-bond-film.html

    BUT post just next to it shows up messed up
    http://www.indianuncle.com/wp/2005/10/memory-clinic.html

    I have imported this blog from blogger.com, does it has anything to do with this. Permalink Structure without ending .html works just fine.

    Any suggestions, help?

  2. Beel
    Member
    Posted 9 years ago #

    The inconsistency does seem to be a bit odd. Do you actually have a directory structure of wp/20005/10 ? I get a "Forbidden" instead of the expected "Not Found"

  3. dshah
    Member
    Posted 9 years ago #

    Ohh god! Thanks for pointing it out.

    Actually there is directory structure like it, it was created during the process of blogger.com blog migration. So when I tried to access the page, I was actually getting the .html file from server and not the permalink.

    I renamed that dir and things are working fine!

    Thanks Ton :)

  4. Beel
    Member
    Posted 9 years ago #

    Glad you got it, now can you mark this thread as resolved? Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic