Support » Plugins and Hacks » [Resolved] permalink structure problem ?

[Resolved] permalink structure problem ?

Viewing 12 replies - 1 through 12 (of 12 total)
  • just found a bug probably related to this.
    Even if you modify the Capability Type options while creating a new type, this one keeps at “post” value

    I cannot change it to page.
    Where can I do that ?

    Plugin Author Michael Beckwith


    Not quite sure where you’re seeing this issue. I just tested it with a localhost install and it’s saving the capability type as page. Is it doing the same for you but not accepting anything but “post” for capability type?

    btw, I’m not sure it is the problem here with my permalink / url stuff..

    Plugin Author Michael Beckwith


    May be worth flushing your permalink rules to make sure. Just visit the permalinks settings page, and that should do it.

    I flushed the permalink (just for testing purpose, indeed, flushed, permalinks give me errors)
    I changed the capability to page and discovered it kept it (but there is a bug when you click on edit: it proposes you post in the text field (but it keeps the right choice)
    I reverted back my permalink structure
    it works…

    weird 🙂

    false positive.

    it doesn’t work.
    should I put the rewrite to false ?


    http://shibashake.com/wordpress-theme/custom-post-type-permalinks seems to explain well what the problem is here.

    Indeed, in the code generated by your plugin, here mine:

    register_post_type('works', array(	'label' => 'works','description' => '','public' => true,'show_ui' => true,'show_in_menu' => true,'capability_type' => 'page','hierarchical' => true,'rewrite' => array('slug' => 'works'),'query_var' => true,'has_archive' => true,'exclude_from_search' => false,'menu_position' => 20,'supports' => array('title','editor','thumbnail','author','page-attributes',),'taxonomies' => array('type',),'labels' => array (
      'name' => 'works',

    there is no option with_front for rewrite parameter.
    If I could put this option to false, it should work.

    is that code inserted in some file ? or is it dynamically used while a page is called by a visitor ?


    I found the problem and added that “statically” in your code
    I replaced the line 131 & 181 by:

    'rewrite' => array('slug' => $cpt_rewrite_slug, 'with_front' => FALSE),

    everything works nice and smoothly now.
    that would be cool to have that option in your plugin

    Plugin Author Michael Beckwith


    Yeah, it may be best to try and use the generated code feature thing and export the CPT settings for the moment if you must. That missing with_front is something I have in the works for version .8 which I hope to have out by this weekend. Just need to debug a couple more things and make sure it’s well tested.

    Glad you got it figured out with some proverbial hair pulling. For what it’s worth, this plugin stores all of the CPT/taxonomy settings chosen as an option in the db, and then fetches/registers with it all.

    ok for the storage in db in option.

    and now all is okay 🙂

    best regards,

    Plugin Author Michael Beckwith


    Marking resolved.

    sure 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] permalink structure problem ?’ is closed to new replies.