Support » Fixing WordPress » Permalink structure no longer works!

  • sashen

    (@sashen)


    For the last 2.5 years, I’ve used the permalink structure:

    /%post_id%/%postname%/

    One reason I did this is so that I could use a “shortcut” URL and get to a post with

    http://www.domain.com/post_ID (without including the postname)

    Since updating to 3.4 (I haven’t installed any other plug-ins), I now get a 404 if I go to domain.com/post_ID.

    I’ve tried “resetting” the permalink structure by changing it to default, and then back… but that made no difference.

    Suggestions? Clues? Or, better, a solution?

Viewing 15 replies - 31 through 45 (of 60 total)
  • Russell Jamieson

    (@powerblogservice)

    The following is a temporary fix until WordPress fix this serious bug in their permalink handling:

    Add a couple of lines to your .htaccess file after the RewriteBase line

    RedirectMatch 301 ^/(\d+)/$ http://www.yoursite.com/?p=$1
    RedirectMatch 301 ^/(\d+)$ http://www.yoursite.com/?p=$1

    This matches URLs ending in /%%post_id or /%%post_id/ and redirects to the correct post

    dannymoe34

    (@dannymoe34)

    Russel, I can’t use .hataccess file because I have IIS server. You know how to do it with web.config file?

    Also with this problem I stuck with wordpress and can’t continue with my website. I want to change permalinks from the default example.com/blog/?p=123 and moving it to the root so I can use example.com/page-name for pages. But what I will do with my old permalinks? I have active blog with a lot of posts. This is a serious problem of wordpress.

    Russell Jamieson

    (@powerblogservice)

    Danny, I do NOT have IIS so I cannot test this – but it will look a little like this….

    <rewrite>
      <rules>
        <rule name="Redirect1" stopProcessing="true">
          <match url="^/(\d+)$" ignoreCase="false" />
          <action type="Redirect" redirectType="Permanent" url="http://www.yoursite.com/?p={R:1}" />
        </rule>
        <rule name="Redirect2" stopProcessing="true">
          <match url="^/(\d+)/$" ignoreCase="false" />
          <action type="Redirect" redirectType="Permanent" url="http://www.yoursite.com/?p={R:1}" />
        </rule>
      </rules>
    </rewrite>
    sashen

    (@sashen)

    THANK YOU RUSSELL!

    Worked like a charm for me.

    Let’s see when WP actually fixes it.

    taropaa

    (@taropaa)

    @russell Jamieson I tried it and unfortunately that didn’t fix it for me.

    dannymoe34

    (@dannymoe34)

    Thank you Russel but I don’t think it’s possible to fix it via hatacces or web.config. If I change the permalinks from example.com/blog/?p=123 to example.com/blog/post-name ,Someone must fix this issue on wordpress files.

    Russell Jamieson

    (@powerblogservice)

    Hi Danny, Yes let’s hope WP gets this fixed in the next release

    dannymoe34

    (@dannymoe34)

    Someone need to report this problem to wordpress developers team

    taropaa

    (@taropaa)

    dannymoe34

    (@dannymoe34)

    Someone know what is the function who control this redirect? Maybe we can restore it from the old version and offer to the others in meantime

    RoxyJo

    (@roxyjo)

    Just wanted to say that I am having the same issue. The default permalink structure works, but the postname permalink structure does not work, this seems to happen to newly added sub- pages..

    dannymoe34

    (@dannymoe34)

    RoxyJo, you have IIS server?

    rcbrothers1

    (@rcbrothers1)

    Updated SQL, deactivated all plug-ins, then upgraded to wp3.4. Immediately following upgrade, all inbound links to posts are broken: “The page isn’t redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete.”

    Very “plain vanilla” site, minimal plug-ins and only the customization options provided within the wp setup.

    Site
    http://market-intel.com/blog
    Example of broken link:
    http://market-intel.com/blog/2012/06/11/better-marketing-starting-tomorrow/

    I’m only modestly proficient with wp’s internal code, so a solution that a lay-person can handle would be appreciated.

    RoxyJo

    (@roxyjo)

    Hi dannymoe34,
    no the server is a linux server (can they be iis, or is it only windows?)

    rcbrothers1:
    Try changing your permalinks to default, and then back again to custom.

    dannymoe34

    (@dannymoe34)

    i found this ticket http://core.trac.wordpress.org/ticket/10187
    The permalinks was fixed on IIS for pervious versions of wordpress but why it’s not working now? in 3.4 it doesn’t work

Viewing 15 replies - 31 through 45 (of 60 total)
  • The topic ‘Permalink structure no longer works!’ is closed to new replies.