Support » Plugin: Media Library Assistant » Permalink (slug) disappeared

  • Dear David,
    thanks for excelent plugin. I cannot imagine how I can manage my homepage without it.

    Now a little problem. Earlier I can edit permalink easily. And no, answer is not “settings -> permalink”. Also “Media, edit file, and there you can see text permalink, click EDIT and change permalink”. (Click “edit”, maybe I need any special eyeglasses I can see it…)

    Earlier I can make this. “Media” -> “Assistant” and edit file. There was a little field named “slug”, editing it was possible change permalink. Earlier: I have document named eg. d10000771a.pdf, media->assistant-> add file, and then, homepage.fi/d10000771a is permalink. Earlier I simply go to “slug” and change this eg. d10000771. Suddendsly this excelent preference disappeared.

    Is it any settings in MLA (or wordpress…?) take this back?

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author David Lingren

    (@dglingren)

    Good to hear from you again. Thanks for the positive feedback and for your question.

    WordPress has changed the Edit Media page to eliminate the ability to alter the name/slug value for a Media Library item. This happened a few updates back but I do not remember exactly when.

    You can use the Media/Assistant Quick Edit area to change the Name/Slug value. Use the “Quick Edit” rollover link on the item you want to change. I just tested this on a WP 5.7 installation and it seems to work safely. Make sure whatever value you change it to is unique, of course.

    I am marking this topic resolved, but please update it of you have any problems or further questions regarding the above suggestions. Thanks for your continued interest in the plugin.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.