Support » Fixing WordPress » Permalink settings change messed up all my posts

  • Hello,

    As per the recommendation of Yoast SEO, I changed all the permalinks to ‘post name’ format(https://www.truepush.com/blog/sample-post/). Now when I click on any post it says ‘The requested URL /blog/xyz/ was not found on this server.’ The links come back alive when the setting is changed to ‘plain’ format(https://www.truepush.com/blog/?p=123). That too not all the posts, only a certain majority of them. We’ve created a .htaccess file and placed it in the root folder along with the index.php file. Can you please help us out with this issue? Thank you.

    • This topic was modified 3 months, 2 weeks ago by  harry257.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi,

    Except the first one other links are working. The probable reasons are :

    1. .htaccess file is not present in the WordPress installation root folder
    2. .htaccess file is not writable.
    3. mod_rewrite is not enabled in your server

    please check the above points

    Thank you, @tristup . The reason why the first link is not working is that we used a custom URL which is not being updated in the server(I guess). And the rest of the links are present in ‘plain’ format, that’s why they are working.

    Take this link for example: https://www.truepush.com/blog/api-integration-for-android-studio/ Even when we change the permalink settings the URL is not getting updated and the link remains broken.

    Still trying to figure out a full-fledged solution. Will definitely take your pointers into consideration and let you know if they worked. Thanks again!

    Hi @harry257,

    Thanks for informing me.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.