WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Permalink Settings

[Resolved] Permalink Settings

  • Hello,

    If i set the Permalink Settings to anything but Default the pages stop working. Rather i get the HTTP 404 error (The resource cannot be found.).

    I am hosting it with godaddy on Windows server with IIS7.

    Means it works when Default is selected.

    Thanks!!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Well none of the suggestions worked for me. Actually most of them require me to have admin rights on the server which i don’t have.
    This is godaddy shared hosting (deluxe) and it runs Windows Server 2003 and IIS 7.0.
    Any other ideas? Thanks!

    Contact your web host, they may be able to help you fix this.

    this seemed very promising http://learn.iis.net/page.aspx/466/enabling-pretty-permalinks-in-wordpress/
    but if i upload the web.config file to the wordpress root dir i get error 500.

    Hi,

    Please do these steps:

    1. Create the file wp-404-handler.php in your base WordPress folder. (you can also download it here).
    2. Set your sites 404 page to point to the wp-404-handler.php url. Most control panels at web hosts allow you to do this. If you’ve got the option to select between FILE and URL then choose URL.
    3. Go to Options -> Permalinks in your WordPress admin page, and choose an appropriate structure for your links. Choose Custom with this pattern:

    /%year%/%monthnum%/%day%/%postname%/

    That’s it!

    Thanks,

    Shane G.

    No .. unfortunately fu*king GODADDY doesn’t allow URL rewriting.
    Can you imagine that they are suggesting me to buy dedicated server for this feature? I can’t fu*king believe !!! To buy dedicated server for just a BLOG? Insane !!!

    so don’t listen to godaddy
    you can switch to a linux server for free in your hosting control center
    log in to it and on right side you will see
    “switch operating systems”
    click that and do it

    Yes i can indeed but i have some ASP.NET sites hosting there.
    I think i will buy a new Linux package at another host.
    Thanks to all repliers!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Permalink Settings’ is closed to new replies.
Skip to toolbar