WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Permalink Question

[Resolved] Permalink Question

  • Hi,

    I have done something wrong but can’t figure out how to remedy. My article links are dead, and the directories don’t exists. I’m pretty sure this has something to do with the permalinks and the htaccess settings.

    Site: CrosslandTeal.com/blog

    Problem: Articles show on main page, but when clicking, on title or category links, they don’t exist. I had previously pasted all the permalink stuff into my htaccess file, but at that time had not set it to 666. It was 664 instead. I have now set it to 666, but the links are still not working.

    In file manager I see I don’t even have a file named:
    /blog/2005/07/23/the-name-of-the-article/

    I’ve only posted 4 things so if needed I can start from scratch. But is there a fix to get things working at this point?

    Thanks
    Steve

Viewing 12 replies - 1 through 12 (of 12 total)
  • wrong link name above, it’s http://www.crosslandteam.com/blog (not teaL). sorry.

    Just delete the .htaccess and empty out all fields in “Options -> Permalinks” and hit “Update Permalinks Structure.”

    All links should work now without permalinks. Then you could re=do the setting-up-permalinks proccess.

    What I’d do:
    – delete the .htaccess file
    – clean up the permalinks structure, i.e. leave the fields empty and click Update Settings (or whatever its name is)
    Check out if it works.
    After that you can go and read carefully the Codex
    http://codex.wordpress.org/Using_Permalinks and you permalinks setting panel to figure out a working solution.

    I have some redirects in my htaccess file that are not related to WP but which are needed to keep search engine indexed links to old pages from showing up dead.

    I suppose I can just delete the WP stuff from the htaccess file, make sure it’s permissions are 666, and try what you suggest above?

    Yes. Remember to backup.

    OK, you are right. Cleared all permalink fields and now don’t have any dead links. Everything is working with the url tags such as /blog/?p=7

    So, if I now have my htaccess permissions at 666, and I go back into Permalinks and set it from scratch again, it will create the directories i.e. /2005/07/23/article-name/ automatically for existing articles as well as all new ones?

    Thanks,
    Steve

    Yes.

    If WP doesn’t successfully updated the .htaccess automatically, it will give you something to paste onto .htaccess.

    Thanks for the help. I appreciate it.

    Just read this at the permalink how-to page:

    “Your server must have mod_rewrite for cruft-free permalinks to work. In addition, you must create a .htaccess file and place it in the directory in which your main index.php file resides. For example, if your WordPress blog is installed at domain.com/wordpress/, put the .htaccess file at domain.com/wordpress/.htaccess. However, if your WordPress installation is in a subdirectory, but your visitors access your site at the top level of your domain, place the .htaccess file at domain.com/.htaccess.”

    Does this mean I need an htaccess file in my /bolg directory? The first part seems to say so, but the second part applies to my site and so I think maybe I don’t.

    Visitors come to mydomain.com and the blog will be linked to from the home page at mydomain.com/blog.

    So I don’t need a second htaccess in the /blog directory if I am understanding the above correctly. Is that right?

    Visitors come to mydomain.com and the blog will be linked to from the home page at mydomain.com/blog
    So WP’s index.php is in mydomadin.com/blog, right? Then you need .htaccess in that directory also, I suppose. Trial and error won’t hurt in this case. Remember to backup the htaccess beforehand.

    If you set up your site so that people go from the root directory to /blog/ to access WP, then it goes in /blog/. If WP loads from the root directory, it goes in the root.

    oops, to slow 😉

    OK, so I need a second .htaccess file then, independent of the one I already have in my domain root. I’ll try that and see what happens.
    Thanks
    Steve

    Ok, thanks for all the help.
    I placed a second htaccess file into the directory /blog. I chmod it to 666. Then I set the Options -> Permalinks field to the format I wanted, clicked “Update Permalink Structure”, and received the message “Permalink structure updated.” It didn’t give me anything to cut and paste like it did the first time. And the links all work now so it must have written to the htaccess file on it’s own without a problem.

    (The long summary is for future dopes like me who have the same problem and find this thread)

    Thanks for the help.
    Steve

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Permalink Question’ is closed to new replies.