WordPress.org

Forums

Permalink Problems (20 posts)

  1. ZacLohrenz
    Member
    Posted 8 years ago #

    My blog is at http://www.zaclohrenz.com/blog/.
    Basically my problem is, if you try to click on the title to read more (or link to the specific post), it gives you a 404.
    I tried changing my permalinks (thinking that was it) but kept getting .htaccess thing where it asks me to add stuff.
    If I add it to my root folder, the page never loads.
    If I add it to the blog folder, I keep getting 404's.

    I am assuming it goes into blog, correct? I even left .htaccess blank, then chmod it to 777, and it still happens. The only way I can get the front page to stay up and running is to not even have a .htaccess file in blog. So how will I fix this problem?

  2. whooami
    Member
    Posted 8 years ago #

    I am assuming it goes into blog, correct? I even left .htaccess blank, then chmod it to 777, and it still happens.

    Whatever the ultimate solution ends up being, do NOT leave your .htaccess with those permissions in the long term. The most 'open' permission your .htaccess should ever have is 644.

    And, just for educational purposes, chmod'ing a plain text file (which your .htaccess is) to 777 does nothing more than chmod 666. 777 is used for directory permissions OR for executable scripts (perl scripts, for example)

  3. ZacLohrenz
    Member
    Posted 8 years ago #

    I realize that... I was just saying I went to the extreeme measures to make sure that it was writable, yet it still did not work.

  4. blork
    Member
    Posted 8 years ago #

    I've just come off a very similar problem (see this thread: http://wordpress.org/support/topic/96746)

    Turns out it was because my host upgraded to PHP 5.2. Apparently there are problems with WordPress and that version of PHP.

    Contact your host and see if you've recently been upgraded. If so, see if they'll downgrade you to PHP 5.1 or lower.

    There may be another solution, but I'm not aware of it. (I just lost a day and a half on this, and as soon as my host put me back on PHP 4 the problem went away.)

  5. ZacLohrenz
    Member
    Posted 8 years ago #

    I am running PHP Version 4.3.11 already...

  6. ZacLohrenz
    Member
    Posted 8 years ago #

    Bump... Still no idea why this is happening.

  7. Chris_K
    Member
    Posted 8 years ago #

    I am assuming it goes into blog, correct?

    Yes.

    There's some good troubleshooting stuff at the Permalinks page, but first you might want to confirm with your host (who is your host, by the way?) that they have mod_rewrite and AllowOverride properly on and enabled.

  8. ZacLohrenz
    Member
    Posted 8 years ago #

    My host is nobody you will have heard of, just an individual who owns a few servers in OR on optical connections.

    I can email and ask if they have mod_rewrite and AllowOverride on, but I have never had problems with this before... Before I did a re-vamp of the blog it worked fine. I wouldn't suppose trying to change the permalink options and such within the Dashboard would cause this much trouble, I have tried all the permalink options and none of them work.

  9. ZacLohrenz
    Member
    Posted 8 years ago #

    BUMP

  10. moshu
    Member
    Posted 8 years ago #

    Do you have other rewrite rules in your htaccess besides the WP rules?
    If yes, what happens if you temporarily remove them?

  11. ZacLohrenz
    Member
    Posted 8 years ago #

    I have one .htaccess kept in my root folder is the only other one I have tried doing anything with.
    All it is used for is error docs (which are getting hit frequently as a result of this permalink problem).

  12. moshu
    Member
    Posted 8 years ago #

    WP needs its own .htaccess file in its folder - i.e. in "blog" in your case!

  13. ZacLohrenz
    Member
    Posted 8 years ago #

    In reference to my original post:
    "I am assuming it goes into blog, correct? I even left .htaccess blank, then chmod it to 777, and it still happens. The only way I can get the front page to stay up and running is to not even have a .htaccess file in blog. So how will I fix this problem?"

    So, yes. I realize it goes into blog.

  14. solidariti
    Member
    Posted 7 years ago #

    I had the same problem, it took me one week of searching through these forums, if you are getting the 403 error or 404 error take a look at this page it helped me straight away.

    http://www.htaccesselite.com/htaccess/wordpress-permalink-403-error-vt171.html

    My problem was 403 error so I did what it recommended which was to insert this in my .htaccess file Options +SymLinksIfOwnerMatch above <IfModule mod_rewrite.c> and above this # BEGIN WordPress so it doesn't get over written and my pretty permalinks /%category%/%postname%/%post_id% which resolve to http://test.dappastyles.com/about/ for my pages worked.

    Hope this helps.

  15. lizv
    Member
    Posted 7 years ago #

    Hi,

    I have just uploaded the most recent version of WP: 2.3. I want to change the permalinks so that I have the title of my posts 'allinurl'.

    When I deselect the 'default' permalink and select: Date and Name based, and then remove the all the coding prior to: /%post%/, save the changes and then check out the blog, the blog appears frozen in time. I try selecting the title, or the 'read more here' link, or any of the sidebar links and it always appears to revert back to the home page. Nothing appears to change.

    When I restore the default, everything is as it was.

    Any ideas about what is happening?

    Thx.
    Liz

  16. moshu
    Member
    Posted 7 years ago #

    When I deselect the 'default' permalink and select: Date and Name based, and then remove the all the coding prior to: /%post%/,

    Don't do that. If you select one of the given structures - do NOT touch it.
    If you want your own: select - custom.

    And before doing anything, read: Using_Permalinks
    (hint: that one tag might be not enough for WP...)

  17. Cheanu
    Member
    Posted 7 years ago #

    Hi,

    I've been working on my blog for 2 weeks and I can't find any solutions.

    I've uploaded my .htaccess file to my blog directory and I can edit and save changes to it from the WP control panel, so i guess it's been set to enable WP to re-write to this file.

    After I've changed my permalink option to Date and Name based, it shows a message that my permalink structure has been updated. I checked my .htaccess file and it shows the codes as per followed:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    But I still can't access my blog posts from my browser, not even the homepage http://4life.cheanu.com (I can browse http://4life.cheanu.com/index.php instead, if I type in the full URL in my browser). I can't browse to my other posts too.

    Please help.

    PS: I'm using WP 2.3

    Thanks!

  18. moshu
    Member
    Posted 7 years ago #

    Look at the error message and read everything there.
    You are on a Windows (IIS) server - that doesn't know what .htaccess is. So, the usual methods will never work on that server.

    Read more: Using_Permalinks

  19. Cheanu
    Member
    Posted 7 years ago #

    Thanks everyone for the reply.
    I've got my index.php figured out and I can now browse directly at http://4life.cheanu.com

    However, I can't jump to my posts if I'm using permalink formats other than the default (ugly permalink).

    I've changed the permalinks format after I've figured out the index.php problem, yet my permalinks are not working. Please help.

  20. syncbox
    Member
    Posted 7 years ago #

    as far as I can tell, you are still using pretty permalinks... for example, if you hover over the link under Categories, it shows:

    http://4life.cheanu.com/category/uncategorized/

    if you were using the default permalinks, this would look something like http://4life.cheanu.com/?p=N (where N is the ID number)

    And if you are on an IIS server, you don't have mod_rewrite

    Suggestions:
    1) use the default method for permalinking
    2) move to Linux

    HTH, I'm sussing out a permalink issue in IE browsers and happen to stumble upon this post in my searches...

Topic Closed

This topic has been closed to new replies.

About this Topic