Support » Fixing WordPress » permalink problem with pages after upgrade to v2.6

  • I upgraded from v2.3 to v2.6 and as a result the permalinks for my pages don’t work anymore (like before). I end up now in a redirect loop specifically for the pages. The blog & posts work fine.

    My setup;
    -Wordpress address in a subfolder: /blog
    -Blog address in the root of my domain
    -Permalink structure: /%postname%
    -Pages with a slug name the same as a subfolder name of this domain.
    Each page lists photo galleries which are located in the applicable subfolder of my domain. So when you click on the gallery link you switch to a gallery (made in photoshop) which has a link back, one level up, like this: ../index.php ; which should display the right page, named the same as the subfolder. (using this structure I can standardize the galleries, and work with different people editing each their page and their galleries).

    This worked in version 2.3, because I had modified the index.php files in each domain-subfolder (for each page) to call the wp-blog-header.php from the wordpress subfolder, like this (note the two dots):


    While the index.php file in the domain root has instead:


    The same setup now in v2.6 doesn’t work anymore. I end up in a redirect loop when I try: Here the subfolder of the domain is named ‘j’ while the page slug name is also ‘j’.

    I discovered that v2.6 handles the .htaccess file differently from v2.3
    In v2.6 it inserted in .htaccess;

    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    While in v.2.3 it inserted the WordPress address in .htaccess;

    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]

    I suspect this is part of the problem; but I haven’t been able to solve it. Any tips or solutions would be welcome!

    Note: My server runs PHP 4.4.8, mySQL 5.0.51, Apache 1.3.37 and I have been researching this problem on and trying several things, to no avail.

Viewing 1 replies (of 1 total)
  • Update: I’ve temporarily renamed the slug for the page given as example; which means it doesn’t show the problem.

    Nevertheless my problem is still not solved; I would appreciate suggestions for a solutions!

Viewing 1 replies (of 1 total)
  • The topic ‘permalink problem with pages after upgrade to v2.6’ is closed to new replies.