Support » Fixing WordPress » Permalink problem when use aliased directory

  • I installed my wordpress this way:
    1)install xampp in my computer
    2)set an aliased directory in httpd-xampp.conf:
    Alias /wordpress2 “C:/xampp732/wordpress511/”
    <Directory “C:/xampp732/wordpress511”>
    AllowOverride AuthConfig
    Require all granted
    ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </Directory>
    3)copy wordpress files to C:/xampp732/wordpress511
    4)launch “localhost/wordpress2” to install WordPress.
    Everything works perfect!!
    But after I changed my permalinks to anyting other than plain, the error 500 comes!
    What’s the problem?
    Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator t-p

    (@t-p)

    But after I changed my permalinks to anyting other than plain, the error 500 comes!

    If the default setting works, then try reading Using_Permalinks

    Yes, it works.

    I am sure it is caused by the alias setting.
    No it, no problem.
    Here is my .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress2/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress2/index.php [L]
    </IfModule>

    # END WordPress

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Permalink problem when use aliased directory’ is closed to new replies.