Support » Installation » Permalink problem after upgrade

Permalink problem after upgrade

  • BrokenPerfection


    URL: http://brokenperfection.com/blog1
    Host is Yahoo!

    I cant seem to get the permalinks to work on my blog after I updated to 2.3. this is the error I get when clicking on them:

    Error: The page isn’t redirecting properly

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    * This problem can sometimes be caused by disabling or refusing to accept

Viewing 15 replies - 1 through 15 (of 23 total)
  • Chris_K


    As I recall, the only way pretty Permalinks work with Yahoo is if you’re running their permalink plugin.

    Are you?



    Yes it is running



    If you disable their plugin, and set your Permalinks to default, do things work?

    If their permalinks plugin is breaking things, I’m afraid you may have to contact Y! directly to see if they’ll be fixing/upgrading it soon.



    HA you rule! Thats what it is.. I work for yahoo! so I will see what I can do about this when I get into to work tomorrow..



    Sweet — it would be very helpful if you let us know how that goes. 🙂

    I bet you won’t be the last one trying the upgrade.



    Ok so a ticket to Y! enginerring has been sent.. However is anyone Knows why the Yahoo! permalinks plugin breaks permalinks in 2.3 or wants to give it a shot and try and fix it heres the code I pulled it from the php file:

     * Copyright (c) Yahoo! Inc. 2005. All Rights Reserved.
     * This file is part of Yahoo Permalink Plugin. The Yahoo Permalink Plugin
     * is free software; you can redistribute it and/or modify it under the terms
     * of the GNU General Public License as published by the Free Software
     * Foundation under version 2 of the License, and no other version. The Yahoo
     * Permalink plugin is distributed in the hope that it will be useful, but WITHOUT
     * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
     * GNU General Public License for more details.
     * You should have received a copy of the GNU General Public License
     * along with the Yahoo Permalink plugin; if not, write to the Free Software
     * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
    Plugin Name: Customizable Permalinks
    Plugin URI: http://smallbusiness.yahoo.com/webhosting/
    Description: Help drive and retain traffic to your site with the Customizable Permalinks plug-in, which enables you to give your readers easily understandable, static web addresses (URLs) for your pages. Customized permalinks make it easier for your readers to bookmark and share your blog posts.
    Author: Yahoo! Web Hosting
    Version: 1.0
    Author URI: http://smallbusiness.yahoo.com/webhosting/
    function update_permalink_file() {
      if (isset($_POST['permalink_structure']) ) {
        if(empty($_POST['permalink_structure']) ) {
          unlink(get_home_path() . '.plink');
        } else {
          touch(get_home_path() . '.plink');
          unlink(get_home_path() . '.plink');
      } else if(strcmp($_GET['activate'],"true")==0){
          touch(get_home_path() . '.plink');
      unlink(get_home_path() . '.htaccess');
    // Now we set that function up to execute when the admin_footer action is called
    add_filter('mod_rewrite_rules', 'update_permalink_file');
    add_action('mod_rewrite_rules', 'update_permalink_file');


    Mark Jaquith of Mark on WordPress discusses WordPress 2.3 Canonical URLs and the problems they may cause.

    He has a one line plug-in that disables canonical URL redirection.

    I installed the plug-in and reactivated the Yahoo! plug-in. Everything works now. I will use this until Yahoo corrects its issues – or until I move to a different provider.




    Is this all you had to do to upgrade Yahoo to 2.3? I want to do the same and not familiar with making files writable and stuff. I upgraded to 2.3 then had to put my backup back on because the permalinks would not work — are there any other problems because if not then I will try again with this solution… thanks very much for posting this!!!





    Yes, that’s it – and it worked perfectly.

    An aside is that I always get database update errors when I upgrade – and there are database changes in version 2.3. I have to manually run the SQL statements. After doing that it works fine, but that may just be a problem with my Yahoo install and security structure.

    At the present time I’m just too lazy to leave Yahoo – but the day is drawing closer…

    We switched to 2.3.1 recently and noticed the site was slow..After troubleshooting found out that the customizable permalinks was the cluprit .Took it out..Now its fast.Check out our site at bloggermoms


    I am running wp 2.3.3. The site is hosted on Yahoo. The yahoo custom permalinks plugin is installed an activated.

    I have also installed the plugin to disable canonical URLS. I still cannot get permalinks to work correctly. The site in question is http://www.showukare.com.

    An example of the problem is http://www.showukare.com/faq.

    I have a page with the page slug of “faq” but it will not load. The page will load is you use the default link structure:

    Is there anything I can do to get this to work with this setup?

    Essentially the new yahoo permalink plugin already disallows the cannonical urls. however there’s nothing you can do if installing WP in the root directory.

    If you are simply moving to a different directory, yahoo has an interface to change the directory name to fix the permalinks. It’s under the “Blog Manager”. Ref http://help.yahoo.com/l/us/yahoo/smallbusiness/webhosting/wordpress/wordpress-26.html

    Varun, is there anything else you did to set this up? You seem to be the only one I’ve found who got permalinks to work correctly with yahoo. I installed the new Yahoo Permalink Plugin (with the disallow cannonical urls line), but it still only works if I include the “index.php” in there. I have found people who have setup permalinks with yahoo, but they all included the blog directory, e.g., “http://mysite.com/blog/welcome-to-mysite”.

    Here’s the blog Im trying to setup:

    Any ideas would be appreciated. Thanks!!


    Has anyone succeeded here to get rid of index.php from the url?

    if so, please provide what you did to fix this on Yahoo! please.


    My Yahoo! Customizable permalink plugin is not even being activated when I upgraded from 2.0.2 to 2.5.1
    Database errors was a long list when I upgraded!

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Permalink problem after upgrade’ is closed to new replies.