Support » Fixing WordPress » Permalink Problem (404 error)

  • Resolved DrSushi

    (@drsushi)


    I have encountered a very weird problem with my permalink (/%category%/%postname%/). As happened to others in this forum I get 404 “object not found” error. I talked to my host who couldn’t find server related problems.

    My .htaccess reads this:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    I spent hours trying to find a solution on the web and in this forum. I certainly don’t have this problem (no DNS server and no 500 error).

    Even if the mod_rewrite is working correctly (server wise) it seems like the .htaccess rule is not properly directing the URL info to the index.php. In fact, adding “/index.php” to the permalink works. So I suspect a false rewrite rule.
    I have absolutely no idea how to write rewrite rules, so maybe someone with expertise in this field has a suggestion?!

    If you wanna see yourself: http://www.thealmightyhelmet.com.

Viewing 1 replies (of 1 total)
  • I called my ISP again and apparently I needed to upgrade my tariff. Duh!

    Well, not .htaccess is working properly.

    Customers of Host Europe should be aware that custom .htaccess rules are available with at least WebPack L 2.0!

Viewing 1 replies (of 1 total)
  • The topic ‘Permalink Problem (404 error)’ is closed to new replies.