Support » Plugin: Events Manager » permalink problem

  • I have searched everywhere and haven’t found the answer.

    I believe the problem is that I have wordpress core files in their own directory.

    the problem is the links to the events on the event calendar are rewritten with the directory name, but that isn’t where the event is located so I get a 404.

    I am sure I explaining this poorly so there is a link to events page, clicking on an event will show 404

    (I have tried “Go to Events > Settings > Pages in the admin menu and set ‘Disable title rewriting?’ to Yes in the Events List/Archives panel. When you do this, just below you’ll also have an option of formatting the secondary title that is inserted as a result.” but it doesn’t seem to help)

    Thank you
    RandyC

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • No Randy, that is not the reason, because that is not how WP works.
    Have you tried flushing the permalinks?

    Dashboard > Settings > Permalink > Update.

    Thread Starter Sparkey

    (@sparkey)

    Thank you Patrick for helping,

    Yep, I have updated permalinks multiple times, everytime I change a setting at EM I believe.

    Not sure what you meant by “that is not the reason, because that is not how WP works’

    But I had decided that EM must be looking at the WP General Setting: “WordPress Address (URL)”

    for creating the links??

    • This reply was modified 1 year, 11 months ago by Sparkey.
    • This reply was modified 1 year, 11 months ago by Sparkey.

    I believe the problem is that I have wordpress core files in their own directory.

    That is not (exactly) how WordPress works. 😉

    What have you filled out in Events > Settings > Pages > Permalink Slugs?

    Thread Starter Sparkey

    (@sparkey)

    So I thought you had it, because I found “events” in that setting

    I changed it to upcoming-events and flushed permalinks and it still added “WordPress Address Directory”

    I disabled Events > Settings > Pages > Event List/Archives Disable title rewriting?

    flushed again

    reenabled flushed again

    still adding the “WordPress Address Directory”

    By the way I just moved the website live this morning and it was easier to move all the core files to their own directory— so all the events were created in the old sandbox location originally.

    Also I have since run “Better Search Replace” a couple of times once to replace basic links and another time to change the locations of images.

    But I decided that EM was creating these links?

    Thank you again! for all your time

    Thread Starter Sparkey

    (@sparkey)

    I gave up,

    I haven’t marked this resolved but I went ahead and moved the core files to the root folder and gave up on having the separate directory for them.

    Now the Events manager plugin is creating permalinks correctly, so as far as I can see, what I was trying to do isn’t possible with this plugin, which is no big thing after almost 15 years of playing with wordpress I don’t feel like I have ever made that work.

    As a matter of fact the Wp Admin bar wasn’t working either, I am surprised how much I count on that thing I hated at first!

    Again Thank you Patrick for trying!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘permalink problem’ is closed to new replies.