Support » Fixing WordPress » Permalink option not showing in "New Post"

Viewing 3 replies - 1 through 3 (of 3 total)
  • The way it is supposed to work is that you type a title for your post, then go to the editing box and type in your text. Once there is text in the title box and you have tabbed or clicked out of it, the permalink edit option should show up.

    How are you creating your posts? And how is the behavior of the editing pane different from what I’ve described?

    Edit to add: the “get shortlink” and “view post” items don’t appear until after the post is published, but the “edit” button should appear as soon as you click out of the title field, assuming you entered text into it.

    I know something ain’t right, from my previous experience. I used to type a title and then as I was writing the text in the txt editor, the edit button for the link appeared, but not know. I have to publish the post first, and then it appears.

    Ok, just making sure. Try the basic troubleshooting steps for WordPress and see if you come up with anything. If you have any sort of plugin that deals with permalinks, that’s probably the first place to check.

    Basic Troubleshooting:

    • flush any caching plugins you might be running, as well as server and/or browser caches.
    • deactivate all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Sometimes, an apparently inactive plugin can still cause problems.
    • If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin (read if you need help).
    • switch to the Twenty Eleven theme to rule out any theme-specific problems.
    • If you can’t log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.
    • manual upgrade. When all else fails, download a fresh copy of the file of 3.5 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first:
    • check the Master List to see if you’re experiencing a known issue:
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Permalink option not showing in "New Post"’ is closed to new replies.