WP Glossary
[resolved] Permalink not working (4 posts)

  1. Stefan
    Posted 2 years ago #

    Hi TCBarrett,

    first of all: many thanks for your great plugin.
    I just tested in a test-multisite-installation and it worked just fine.
    Now in my "staging"-environment with a multisite wordpress I only get a 404 when viewing the Glossar Terms (atoz is working fine).

    Multisite is with "subdirectories": Main-Blog and "/de/" and "/en/"-Version.
    I've activated WP Glossary in the "DE"-Version and created the term "usb" which has the permalink: /de/glossary/usb
    When viewing the site, I only get "not found"

    I already deinstalled and installed again. I know this is kind of unspecific, but nevertheless ... do you have any idea
    (and yes I already updated the permalinks, I even deleted the rewrite_rules from *_options-table in the database)

    Do you have any further ideas.

    Thank you in advance

    By the way, when running with WP_DEBUG, I get some warnings.
    For e.g. in
    wp-glossary.php on line 50

    get_plugin_data returns an array, so it should be:
    $in_file_version = $plugin['Version'];

    And your option-key is named: tcb_vesion_check_glossary
    I think it should be: tcb_version_check_glossary


  2. Stefan
    Posted 2 years ago #

    I forgot to say: other custom post types are working well and could be seen with their corresponding permalinks.

    WordPress-Version is: 3.4.2

    At first I had a post that's named "Glossary" with the permalink "/de/glossary/".
    I thought, that this must be the cause.
    I deleted every trace of this post (even the revisions), so this couldn't be the cause anymore.

    And I don't have a translation, so the slug is really "glossary".

  3. Stefan
    Posted 2 years ago #

    Ok than ... sorry for talking with myself :-)
    I just found out that it has something to do with the "responsive" theme.
    With the default "twenty eleven"-theme it works like a charm.

    Sorry for bothering.

  4. Stefan
    Posted 2 years ago #

    Once again for all people having the same issue.
    I've used a child theme of the "responsive"-theme.
    The solution was to simply copy "single.php" to "single-glossary.php" to provide a template for the custom post type "glossary"
    I thought the theme would simply fall back to "single.php" but this is obviously not the case.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Glossary
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.